Vim: Deletion and Adding newline doesn't work in insert mode

Steps to reproduce

First make sure to remove assigned hotkey on obsidian
Search & replace in current file = Blank

Go into insert mode by pressing i
→ Press Ctrl+j
→ Press Ctrl+h

Expected result

In default vim environment,
Ctrl+j acts like an enter key, thus creates a newline
Ctrl+h acts like a backspace key

Actual result

Pressing both shortcut keys


  • Operating system:
    This is not a problem to an OS
  • Debug info:
    Obsidian version: v0.15.9
    Installer version: v0.15.9
    Operating system: Windows 10 Pro 10.0.19044
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Minimal
    Snippets enabled: 1
    Restricted mode: off
    Plugins installed: 6
    Plugins enabled: 6
    1: Style Settings v0.4.10
    2: Minimal Theme Settings v5.3.2
    3: Obsidian Tabs v1.0.5
    4: Admonition v9.0.3
    5: Relative Line Numbers v2.0.1
    6: Vimrc Support v0.7.2

Additional information

Yes, it seems like those two commands are the only one not supported. Others like Ctrl+W inside of insert mode works fine. Also you must disable the default assigned hotkey in obsidian for it to work → Close Active Pane = None

That’s not a bug, it’s just not implemented.

You can make a FR here:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.