VIM + Code Block: turn off 'tab to indent' (happens in middle of the line

Hey all,

Brand new here but have been searching around for the answer and haven’t found much.

When editing code in a code block (in any syntax), using tab to add white space in the middle of the line, indents the whole line as if I went into visual mode and hit ‘>’.

Any way to turn off this behavior?

I have VIM mode on, turned off ‘Use Tabs’ and set tab length to 2.

If this is a redundant question, super sorry in advance.

1 Like

I think this is the same desired tab handling as https://forum.obsidian.md/t/create-tabs-or-spaces-at-the-position-of-your-cursor

No solution there yet either but I wanted to link the two and bump as I am having the same problem

1 Like

Yep - that’s the problem. Thanks for the link :slight_smile: