Vim broken - in latest update (0.13.25+26)

since 013.25 and even after the fixes in .26
vim normal mode commands don’t work anymore

Steps to reproduce


I tried different themes
tried safemode on
updated all the

  • themes
  • community plugin

no avail

  • help vault
  • legacy editor

Vim works as expected


now using again as before blue topaz theme
being in source view edit mode
switching on VIM
make sure I am in normal mode by esc
trying various commands

  • foremost the insert “i”
  • or go to beginning of line “0”

Expected result

  • start writing at cursor
  • jump to line start

Actual result

  • for “i” it just inserts “i” – with no further edit mode
  • for “0” just inserts 0 at line start – with no further edit mode


  • Operating system: macOS 12.2.1
  • Debug info:
    Obsidian version: v0.13.26
    Installer version: v0.12.3
    Operating system: Darwin Kernel Version 21.3.0: Wed Jan 5 21:37:58 PST 2022; root:xnu-8019.80.24~20/RELEASE_ARM64_T8101 21.3.0
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: on
    Live preview: off
    Legacy editor: off
    Base theme: dark
    Community theme: Blue Topaz
    Snippets enabled: 5
    Safe mode: off
    Plugins installed: 138
    Plugins enabled: 96
    1: Day Planner
    2: Calendar
    3: Recent Files
    4: Workbench
    5: Folder Note
    6: Checklist
    7: Hotkeys++
    8: Kanban
    9: Show Current File Path
    10: Text Format
    11: Format Hotkeys
    12: Markdown Formatting Assistant
    13: Prettier Format
    14: Daily Activity
    15: Flashcards
    16: Vault Statistics
    17: Advanced new file
    18: Spaced Repetition
    19: Autocomplete
    20: Obsidian_to_Anki
    21: Templater
    22: Hotkeys for starred files and searches
    23: Tag Wrangler
    24: Footnote Shortcut
    25: Advanced Tables
    26: Underline
    27: Pluck
    28: Privacy Glasses
    29: Related Notes Finder
    30: Better footnote
    31: Relative Line Numbers
    32: Daily Stats
    33: Activity History
    34: Embedded Note Titles
    35: macOS Keyboard Navigation
    36: Metatable
    37: Auto Link Title
    38: Supercharged Links
    39: Obsidian Query Language
    40: MetaEdit
    41: Remember cursor position
    42: Zoom
    43: QuickAdd
    44: Jump to link
    45: Table of Contents
    46: Journey
    47: Tracker
    48: Quick Switcher++
    49: Focus Mode
    50: Hotkeys for templates
    51: Icons
    52: Incremental Writing
    53: Juggl
    54: Find and replace in selection
    55: Pandoc Plugin
    56: Outliner
    57: Custom window title
    58: Plugin Changelogs
    59: File Explorer Note Count
    60: Code block from selection
    61: Dataview
    62: Buttons
    63: Hide Sidebars When Narrow
    64: Breadcrumbs
    65: Highlight Public Notes
    66: Linter
    67: Luhmann
    68: Block Reference Counter
    69: Hover External Link Plugin
    70: DEVONlink
    71: Rich Links
    72: Dangling links
    73: Tag Page Preview
    74: Timelines
    75: Advanced Appearance
    76: Various Complements
    77: Quick Explorer
    78: Liquid Templates
    79: Note Refactor
    80: Paste to Current Indentation
    81: Table Extended
    82: metatemplates
    83: Reminder
    84: Hotkey Helper
    85: Review
    86: Natural Language Dates
    87: Admonition
    88: Advanced URI
    89: Metadata Extractor
    90: CSV Table
    91: Things Logbook
    92: Markdown prettifier
    93: Copy as Latex
    94: Theme Picker
    95: Style Settings
    96: Sliding Panes (Andy’s Mode)

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

Additional information

I don’t understand. Does it not work in the help vault?

As mentioned: It does work as expected in

  • help vault
  • legal editor mode

But not in any new live preview editor setting

  • not with themes disabled
  • not with safe mode i,e. all community plugins disabled

We don’t provide support if for third-party plugins/themes.
So you need figure out which theme or plugin is causing this and report to them.

fully understood. No one can expect that.

But when I disable themes (choosing “none”) and plugins (“safe mode”) - shouldn’t it be the same as help vault?
And VIM itself is core feature.

Plus all worked fine ever since till latest two updates. That made me report it here

Pls help me to understand: Where do I think the wrong way?
is Safe-mode + no-theme not equivalent to clean vault like help vault?

maybe some plugin didn’t cleanup and you need to restart obsidian?

did that several times - no avail

can you post a screen recording of your vault with no theme, no plugins and show me this bug happening?

Also do you get errors in console? cmd-opt-i?

thanks for your precious time here.
Indeed, after how many times trying all the above, this time the no+no+restart did the trick and Vim works. theme active works too. bring the plugins back: broken.

Means: you are right. It’s one of the plugins.
And this leaves me with testing them out one-by-one.

So, if I were to search for the culprit - is “all plugins separately disabled” the same as “safe mode”

you can try divide and conquer to figure out which one is causing this problem.

1 Like

:slight_smile: thx again. I really appreciate your work

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.