Vileplume - a dark theme

@smooth_black_rock last attempt:

.cm-s-obsidian .cm-header-1,
.markdown-preview-view h1 {
  font-family: Arial;
  font-size: 18px;
}

Hi there! So glad you like my theme!

I see @Klaas has been doing an amazing job supporting in my absence, so sorry about the delay!

I’m working on a couple of fixes for you. It’s 10:16pm where I am but I should hopefully have something for you before bed, please hold :slight_smile:

Hi @smooth_black_rock , i’d like you to do a couple of things:

First, update Vileplume in the Obsidian settings with this update button:
image

Next, download this snippet, put it in your .obsidian/snippets folder, and turn it on from the Appearance menu in Obsidian. Hopefully this gives you the look you want!
vileplume-heading-mod.css (350 Bytes)

Also Klaas, wanted to say thank you again for the support - I’m not sure how you do it! I’ve been seeing you everywhere - both my themes, Discord, looking after everyone’s themes not just mine!

1 Like

Thank you! A thing of beauty!

And for the final bit…if there was a way to shave off some size on each heading, so that H1 and H2 were maybe 20% smaller (…and then scale H3, H4 to be proportional, ending up with H4 being only a tiny bit larger than normal bold text)

I love the font and colours!

1 Like

Glad it worked!

I’ve attached a new snippet with some additional selectors. See each line which says font-size. You should be able to adjust those to suit your taste. I’ve adjusted it a little to guess what you might want, but you should be able to do the rest on your own to suit you :slight_smile:

vileplume-heading-mod.css (725 Bytes)

Nice, thank you. And where is the section where I can change the size of the hash?

If you look for this line:

.cm-formatting.cm-formatting-header {
    font-size: 1rem;

You can change font-size here to anything you like. I was a bit cryptic and used rem, but you can use px here if you prefer of course

Bearing in mind 1rem = 16px.

thanks!

Hello. I recently discovered Obsidian and this fantastic theme. I had almost the same desires for change as @smooth_black_rock so I was very pleased to find this thread. However, I must be doing something wrong because the font sizes of my headers are not changing. I’ve added the snippet to the snippet folder and activated it in the Appearances section of the Obsidian settings. I know something worked because the font style of the h1 headers is now the same as the rest, but despite my editing of the font sizes in the snippet, the header font sizes don’t seem to change. I’ve tried restarting Obsidian, switching back and forth between themes, and turning the snippet on and off.

It must be something I’m doing wrong, but I don’t know what. I edited the file and I restarted Obsidian… what else is there to do?

Is someone willing to help me? Thanks.

Hi there! So sorry I didn’t reply to you, I don’t check the Obsidian forums much anymore. I’ll look into this

This should be resolved with VilePlume 1.0.2 :slight_smile: