Vertical text height limit is far too short

Steps to reproduce

Create a CSS snippet with this in it:

.vertical {
  writing-mode: vertical-rl;

Create a note with a long single line of text, then at the top, insert this:

cssclass: "vertical"

Expected result

In edit and reading mode, the text should be aligned to the top right corner, and the line should wrap only once it is near the bottom of the screen.

Actual result

In edit mode, the text is vertical and right to left but it starts in the top left corner. In view mode it is correctly in the top right corner but the line wraps very far from the bottom of the page.


  • Operating system: Windows 10
  • Debug info:

Obsidian version: v1.0.3
Installer version: v1.0.3
Operating system: Windows 10 Home 10.0.19045
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: TEST_THEME
Snippets enabled: 1
Restricted mode: off
Plugins installed: 1
Plugins enabled: 1
1: Excalidraw v1.8.4

Additional information

1 Like

we don’t take bugs involving css here. Either post it in developer and API or discuss in the appearance channel on discord.

Ahh sorry about that, I’ll ask in the Discord, thank you.

In case anyone else has this same issue, it can be fixed by also adding this to the file (someone else figured this out for me):

.markdown-reading-view .vertical p {
	height: 85vh;
1 Like

I’m also writing a CSS snippet to enable vertical writing for Chinese, Japanese and so on. But I’m facing many problem.

Wish to talk about it with you.