Vault won't index after updating installer to latest version on Ubuntu 22.04

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

What I’m trying to do

I noticed a message today that I need to update the installer manually to a new version. I did this and upon opening Obsidian again my vault wouldn’t index, it gets stuck on 118/358 (it’s always been fine before). I did some google-fu and tried some of the suggestions:

  1. I bisected my vault to identify any individual file names that the parser might be having issues with and both halves of the vault ended up indexing quickly with no errors.
  2. Uninstalled Obsidian (flatpak) and rebooted and reinstalled Obsidian (flatpak) and rebooted. Indexing still got stuck.
  3. Uninstalled Obsidian (flatpak) and rebooted and installed Obsidian (deb) and rebooted. Indexing still got stuck.

I’m out of ideas. Please help, I just want to use my Vault.

Things I have tried

  1. Bisecting vault > both halves of vault indexed quickly with no issues, complete vault gets stuck
  2. Uninstalling and reinstalling Obsidian on Ubuntu 22.04, first flatpak and then deb versions.

indexing Ubuntu
indexing Ubuntu 22.04
installer update indexing

My usual question (might be boring some):
Are you on X11? Can you try installing deb package?

I’m afraid I don’t know what X11 is. And the deb package is the one I currently have installed.

Ah, sorry. Only saw flatpak.

So I found a workaround. Hopefully this can help someone else who is having the same issue.

WORKAROUND: I copied my vault folder "/home/sync/Vault"into the same folder as a copy “/home/sync/VaultTwo” and opened the copy in Obsidian.

That seems to have done the trick. Everything immediately indexed and nothing got stuck.

I want to be clear that I made no changes to any file names. The files in the copy folder are identical to the files in the original folder.

I wish knew what went wrong when I updated the new installer, but at least it works now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.