Vault load fails when pointing at Box Drive folder

I’ve been using Obsidian for almost 6 months now, and absolutely love it.

I’ve pointed Obsidian at my Box Drive, on MacOS, as my vault.

I’ve been using Box for nearly 10 years, and have tons of knowledge (ie text files and other forms of documents) backed up through there, organized in a folder structure that works for me.

Be advised, there are 100’s of thousands of files in this box drive. Total size of all files together is nearly 300GB in size.

The Problem:
When I open the vault that’s pointed at my Box Drive folder, obsidian sits there for about 5 minutes while it tries to “load my vault.” Consistently, it will time out, and refuse to load my vault.

However, if I close the Box Drive app, and then try to open obsidian and my vault, Obsidian successfully loads said vault.

What I’m trying to do

I’m trying to avoid this lengthy process for successful open of my vault: Ie. on MacOS: first shutdown Box drive application, open obsidian, open the vault that points to my “virtual” Box drive, see obsidian open my vault, now re-load the Box Drive app.

I want to just leave my Box Drive app open as the background app it’s designed to be, and be able to open and close obsidian, along with my vault, whenever I need.

Things I have tried

As mentioned above. When I follow these steps, in order, the aforementioned problem does not occur: 1. close the Box Drive app, 2. open obsidian. 3. load the vault that points to a Box Drive folder 4. wait for obsidian to successfully open step 3’s vault. 5. open box drive app 6. continue work.

However, having to do this process after all restarts is tedious/annoying, and doesn’t address the root of the issue.

Please help me, Obsidian Community. You’re my only hope.

Short answer: Don’t do that. :flushed: (just my personal opinion)

I’m not sure if Obsidian is designed to handle a workflow like that. I personally think it sounds like a very bad idea, even if there is a way to get it to work. Even if it does load when you have Box closed, that doesn’t mean this is a viable way to store things in Obsidian.

In my opinion, consider making a notes vault separate from all your enormous file storage. Obsidian isn’t a filesystem. It’s a note-taking app. By all means, try to put that vault inside Box. But don’t try to capture an entire filesystem as a vault.

But if all your file storage and knowledge is deeply knotted and intertwined, and that works for you, don’t let me stop you from trying! I was just compelled to voice my shock and caution.

I can appreciate that. Unfortunately, files and knowledge files are knotted together. It became too much to control two separate kingdoms. I.E. One tree of folders and files that is only text files. And a second, completely separate, tree of folders and files that are anything else that isn’t a text file. Inclusive of pdf files, binary files, images, videos, compressed zip type of files, etc. . Where both folder structures mirror each other. Too difficult to keep those separated during the chaos of multiple projects, and the need to call up things quickly.

I.E. In my line of work things are already spread across storage that is on remote systems. Bi-furcating my local storage into these two kingdoms was just too much given the already existing external complexities of storage.

For anybody else who comes here, here’s how I solved this for now.

I created softlinks to pertinent folders within my box drive, from a folder that’s physically on my local machine’s hard drive.


On my local machine I created a brand new folder which I will shortly use as an ‘open this folder as a vault.’
mkdir /Users/Mux/Documents/PrimaryObsidianVaultFolder
Then within that “vault” folder I created

cd /Users/Mux/Documents/PrimaryObsidianVaultFolder
ln -s /Users/Mux/Library/CloudStorage/Box-Box/myBoxFolder/something something
ln -s /Users/Mux/Library/CloudStorage/Box-Box/myBoxFolder/somethingElse somethingElse
ln -s /Users/Mux/Library/CloudStorage/Box-Box/myBoxFolder/anotherThing anotherThing

And so on.

then I went to obsidian and opened /Users/Mux/Documents/PrimaryObsidianVaultFolder as a new “folder as vault.” It took a few minutes to index, then showed me the vault and I’m off to the races again.

Anyway, not totally ideal. But works well enough. btw, I’m on MacOS. ymmv on other OSes.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.