V1.5.11 Broke all my links to files stored on a network shared drive

I’m putting this in the help section as I’m not convinced yet that this is a bug.

Here’s my issue:
I have many links in my notes to various documents & media files that I keep stored on a shared network attached storage drive. I work in a Windows desktop environment. These links are all in the form [doc name](<file:///\\device name\folder\sub folder\doc name.pdf>) and these all worked flawlessly until Obsidian self updated itself to v1.5.11. I have been using Obsidian since 2019/2020 so these links have built up over time and have always worked fine.

Now, none of them work. Two things happen when I click the link:

  1. I immediately get a “Remote file warning” pop-up telling me the file is located on a remote server and may not be safe.

  2. Clicking the link from 1 immediately gives me this error msg:

ALL of these links worked fine until the v1.5.11 update then I began seeing msgs 1&2 above.

I did see from this post that replacing “\\” in the link path with “%5C%5” will resolve the error in image 2 above and actually open the linked file, but I still get the annoying overly protective nag screen in image 1.

My questions:

  1. Why now? what changed in v1.5.11 to produce this unexpected behavior. Don’t see anything mentioned in the changelog.
  2. Do I really need to change ALL my links to use “%5C%5” from “\\” ?? That’s a terrible user experience if so and would require much work. …which would naturally bring up questions like: what other nasty surprises might I encounter later on? How much do I want to invest in this platform?? etc.
  3. How do I suppress the nag warning in image 1? I haven’t yet found that as an option anywhere in the settings. These files are on my servers - I don’t need to see this msg for each instance I happen to click a link to my remote servers.

Thanks for reading this far!!

1 Like

I have the exact same problem (which is reported also here).