V1.0 Tab Leaf Width & stacked tabs

Hey, I used to use the Andy Plugin by deathau and was able to have my active note taking the entire available width, now that it has been disabled I have been trying to do the same without success.

When reading the release notes, the release note image make it look like it was possible but I cannot get it to work. Does anyone know if I missed a setting?

188205363-0f24b2a5-3706-4a8c-b38b-7a66baa68ce6

the screen recording is showing what to do.

there’s also a command palette option.

Hello there!
Andy Mode also had nice view option where tabs were positioned side by side in a row without overlapping. Is this option available in v1.0 release?

So, there’s no way to get the tabs to be full width with v 1.0? For reference, I’ll leave an screenshot of how it is displays for me. The tabs do not stack into one side, like in the screen recording.

1 Like

+2

Obsidian isn’t usable now, since this change…

they do for me.

You can work around the problem with the pane relief and style settings plugins

1 Like

Unfortunately, Pane Relief plugin does not help with changing pane width in V1.0

they don’t stack because you have enough space yo show all of them. Open more tabs.

Steps to reproduce

going to stack tabs mode.

Expected result

why my stacked tabs are not fully stacked and appear like this ?


and on the default theme if I shift scroll the closest position is

Actual result

Environment

  • Operating system: windows 10
  • Debug info: SYSTEM INFO:
    Obsidian version: v1.0.0
    Installer version: v1.0.0
    Operating system: Windows 10 Pro 10.0.19044
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: MyShortTheme
    Snippets enabled: 3
    Restricted mode: off
    Plugins installed: 27
    Plugins enabled: 18
    1: Wrap with shortcuts v1.2.0
    2: Templater v1.14.3
    3: Smart Typography v1.0.18
    4: Remember cursor position v1.0.7
    5: Recent Files v1.3.3
    6: Path Title v1.0.7
    7: Obsidian Sage v1.0.1
    8: Image Toolkit v1.3.1
    9: Excalidraw v1.7.24
    10: Essai v1.0.0
    11: Emoji Toolbar v0.3.2
    12: Dynamic Highlights v0.3.1
    13: Duplicate Line v1.0.0
    14: Dataview v0.5.47
    15: Calendar v1.5.10
    16: CodeMirror Options v0.9.5
    17: Contextual Typography v2.2.4
    18: Smarter Markdown Hotkeys v1.16.2

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

Because you have space to show both of them?

No opening side panels or not and with several tabs same (it’s a 24’ screen)

1 Like

What is the problem? I don’t understand you.
what is that you expect to see and why.

wait in the last example, scrolling+shift it’s ok now.
So if there is enough place, with 2 tabs it can’t be fully stacked on left, even scrolling ?
I watched the demo of the last update, and I saw he had 2 tabs well stacked.
that’s why I’m asking. I wanted to see 1 page and not to be disturbed by the other.

So you only want to see one tab a time even if you have the space for viewing more tabs?

an intermediate panel is not reducing. but the behaviour can change. it was the same using sliding panels plugin.

Projet sans titre

So the problem is that intermediate panel is not completely covered?

or

Do you only want to see one tab a time even if you have the space for viewing more tabs?

That is correct. With the plugin we could set this setting:

  • Leaf Auto Width - If on, the width of the pane should fill the available space (also available via command/hotkey) - From Repo Description

It would allow the user to focus on one tab at a time and the current implementation (v 1.0) doesn’t do it. The only workaround I could find was to have a hotkey to unstack the tabs.

Unfortunately it doesn’t do the trick :disappointed:

1 Like

This means that if you have a 40inch screen, you would only see ONE tab with two completely collapsed stacks on each side?

1 Like