Using ChromeBook open existing vault crashes application

Steps to reproduce

  1. Install Obsidian on ChromeBook
  2. Using SyncThing to get files across to the Device.
  3. Open Existing Vault -
  4. App crashes immediately. It appears to be loading possibly workspaces, or something. But I can’t see.

Expected result

The app launches and my vault-files are accessible.

Actual result

Application crash.


  • Operating system: ChromeBook
  • Obsidian version:
    1.0.3 (app-version available on the Play-store)

Additional information

Nullpointer exception at: com.capacitorjs.plugins.filesystem.FileSystem
Source method: getDirectory
Line: 189

I should mention that this exact same method is used on my Android phone which works.

We don’t explicitly support Chromebook and we don’t provide support for third party sync solutions.

That being said, you can try two things

  1. If you can create an empty vault. If Obsidian works on it, it’s likely a problem that you are introducing with your third party sync solution.
  2. If the empty vault doesn’t work, you can try to delete the mobile app and use the .deb version. Install it through crostini (Download - Obsidian).

You may have to disable hardware acceleration on chromebooks because I think it doesn’t work.

Having copied the files over manually from my MacBook compressing the Vault into a zip-file I’m experiencing the same issue. I get the same Crash.

The Sync-solution was just in the interest of full disclosure, but I don’t see how that could possibly interfere at all, but I’ve tried without the sync solution in place and I get the same crash from opening the vault.

But I understand. If ChromeBook is not supported… I obviously cannot expect help in resolving this bug. :sob:

As mentioned above by WhiteNoise these steps should work if it is actually the gpu acceleration that is causing the problem. It worked for me although in a different condition.

  1. Open Chrome Browser
  2. Type “chrome://flags” on the search bar
  3. Search “Crostini GPU support”
  4. Change it from “Default/Enabled” to “Disabled”

we have had people working with the mobile app and with the deb. You can always try to disable the plugins and see if that’s the problem.

Also where are you putting this vault?
Both crostini and android apps for chromebooks run virtualized enviroments, is it possible that you putting your vault somewhere that is NOT accessible by Obsidian?

Additionally, instead of using Obsidian on the Chrome OS you can try running the same on the Linux Beta version that comes with ChromeBooks. It works just fine with Linux Beta(Crostini)

This works when Obsidian is run on Linux

No, I can choose the Vault when opening from Obsidian so it certainly has access to the folder, otherwise I don’t see how I could choose the folder to use as Vault?

Obviously I should admit my complete noviceness when it comes to differences between Android and ChromeOS, but I would have guessed they are somewhat similiar. The solution works on Android.

I’ll try and figure out exactly where the problem lies. Thanks for helping!

Ok, I will try this solution if getting it to work “natively” doesn’t work. Thanks for all the tips!

It would be worthy of mentioning that you will have to install the flatpak version of Obsidian for it to work on Crostini(Linux Beta). The flatpak version is available on the Obsidian website itself

I managed to figure out the error without having to resort to any disabling of features etc. It was simply a case of having a few files named with a colon inside of the filename. Having removed those files Obsidian could start again and my synced-folder appeared as expected.

Acer Chromebook 15 CB515-1HT-P39B
Obsidian Mobile Android app 1.0.3

Open folder as vault is working without a problem.

The folder I am opening is under: /storage/emulated/0/Download/

Well yes, with no files sure. But create a file with a colon inside of it and it will crash.

who said with no files in it? … and yes I try and stick to allowed characters

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.