URI protocol not working in Windows 11

Hey! I’m a bit stuck, would really appreciate any tips to solve this issue.

I can’t determine why but Obsidian is not opening URI protocol links.

for example I tried the URI in the documentation:

If you have Obsidian installed, this link will open the app on your device: Click here

obsidian://open

if I click on it in Chrome I get the correct message:

but after I click “Open Obsidian” nothing happens, Obsidian doesn’t open


Windows and Obsidian’s URI

I read in the documentation that Windows doesn’t need any extra set-up unlike Linux for instance

  • On Windows, running the app once should be sufficient. This will register for the obsidian:// custom protocol handler in the Windows registry.
    Using obsidian URI

Another link example

It doesn’t work if I I right click on a file `copy Obsidian URL)
image

I get the following link format

obsidian://open?vault=demo-1&file=attachments%2Fsample.pdf

but it doesn’t work


Obsidian Version & Other things I tried

As of writing this (2022-04-18) I’m in the latest stable version of Obsidian v.0.14.6

I uninstalled and re-installed the app to make sure the installer version is also the newest

image

I really don’t know what’s causing this issue. I have no idea if it could be a Windows 11 issue or something like that

Thanks, appreciate any help