"Update Available" message keeps reappearing after updating

Since updating to 0.15.9, every time I open a vault I get the message below.


I’m on Linux Mint. The first time I saw it, I updated to the current version by downloading and launching (via Appimage Launcher) the v0.15.9 appimage. But the message never went away. Every relaunch, every new vault, same message.

Anyone else seen this? Or is this problem specific to my installation?



Steps to reproduce

  1. Launch Obsidian.
  2. See message.

Expected result

  1. Launch Obsidian.
  2. Not see message.

Actual result

  1. Launch Obsidian.
  2. See message.
  3. Dismiss message.


  • Operating system: Linux Mint 20.2 Cinnamon
  • Debug info: NA

Additional information

Whatever you think you did to download/reinstall obsidian, didn’t work. You need to look under the hood of whatever AppImage Launcher is doing.

Thanks WhiteNoise. What I did was update to the new version, since the auto-update function of AppImage Launcher claimed it couldn’t auto-update this installation. So I did that.

Now, when I run Obsidian 0.15.9, I’m told (needlessly) that I need to update. Not sure what I did wrong. The initial update “took.” Looking under the AppImage Launcher hood is something I’m not able (nor have time) to do.

Am I really the only one seeing this? If so, I’ll live with it. But I followed every instruction during the update.


I think you may have 2 version installed (old and new) but still running the old version.

These are the instructions I followed:

The “current version” was downrev when I first saw this. Not sure why I’m still seeing this. Very confused.

Interesting. I’ll check. If I nuke both versions (assuming that’s the case) and reinstall, will I lose anything?


no, your vault is not in the obsidian installation.

If you download Obsidian from the website and run it without appimage launcher but directly, what happens?

Thank you, WhiteNoise. Everything now works. I deleted both appimages (moved to Applications/.trash), redownloaded and launched bare. Worked. Then I used AppImage to reintegrate and relaunched. Worked that way too. No message.

Is there a reason not to update to the latest Insider build? Is it pretty stable?

I’m having trouble with Andy mode going off the rails from time to time. Wondering if the new Panes core feature might be more stable.

Thanks for your time on a Sunday.


It is in good shape but only you can make this call.
Andy mode has been implemented natively in obsidian (it’s called stacked tabs). So you can disable/remove the third party plugin once you are on 0.16

Disable Andy Mode before or after the switch?


whenever you want, it’s possible it will get disabled by the update process.

Update the plugins after updating obsidian.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.