Unwanted automatic numbering

When I insert some text with numbers, which is NOT a heading and I want this really to be and remain only text because I copied it from another source with this given numbers in the source, for example:

  1. First heading1 in reference/source 1.1. First heading1.one 1.2. First heading1two …

Obsidian changes the leading “1” into an autonumber.
When I divide the text in rows, Obsidian counts new:

  1. First heading1 in reference/source
    “2” (autodeleted: 1.1.) First heading1.one
    “3” (auto deleted: 1.2.) First heading1two … (don’t know, hot to describe it better)

How do I stop obsidian from this behavior?
In making numbered lists, this behavior is really good and wanted, but in this case not.
Any hints?

As this is part of the markdown syntax for numbered lists, I think you might have a bit of problem. I can see three solutions to your predicament:

  • You can add a dash, - in front of the numbers, so as to make it an ordinary bulleted list, instead of a numbered list, which in turn will make the number into ordinary text
  • You can look into list numbering through CSS to re-create the numbering scheme of the original list (if it follows one). I.e. It could be possible to make the numbering only restart at 1 for each new section (or sub-section) instead of for each new list
  • Potentially you could introduce some stuff in front of the numbers, which serves two purposes: 1) Disable the automatic numbered lists, 2) Act as a target for a CSS selector, which in turn could allow you to reformat the paragraph to your liking. This is although, kind of a hack, but could be done using something like #fixedNumber in front of your list, and some proper CSS…

That brought me to the sufficient idea: I put a slash in front of the row. :slight_smile:

The standard way to use text like 1. at the start of a line in Markdown is to “escape” the period by putting a backslash in front of it (that’s how you indicate that a piece of Markdown syntax is meant to be plain text): 1\.

5 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.