Unique note format should not trim spaces

When creating a new unique note, I would like it to create the note with "2023-05-08 ".

Note the space after the date. This means I can just start typing “Foo”
and get “2023-05-08 Foo”.

Currently the config for Unique notes silently trims the space off the Unique prefix format, so you get “2023-05-08Foo”.

This can be put together using some custom plugins, but with this simple (? :slight_smile: change it doesn’t need to be.

Version: v1.2.7

1 Like

How i can creat Unique prefix format and space in obsidian ???

We are asking for this much needed feature

If this is not selected for implementation, then I found a work-around:

  • visit the unicode browser for 0x200B (“zero-width space”) and click “copy to clipboard”
  • go to settings→Unique note creator
  • append to the end of Unique prefix format one ordinary space character, then hit paste (Ctrl-V or as appropriate for your platform)

0x200b seems to fool trim() into ignoring the space before it, and you’ll get the space you want in new notes.