Unhappy with writing in Obsidian

Things I have tried

<!-- adding an emoji of a question mark. I thought my question mark key was not working in Obsidian. Reading other posts, it seems that Obsidian will not allow question marks. I have added a template of an emoji question mark, but this seems very clumsy, to say the least. I have Keyboard Maestro and I suppose there must be some way to input a question mark. I know I should go to their forum and find out how. But, a question mark is a normal part of writing. I have typed whole essays into Obsidian and then find out that if I paste into for example and email, I get all kinds of strange characters. I suppose you will say, write in an app made for writing. But to me thinking and writing are intimately related. I am not concerned with publishing. I am concerned with thinking. Is there a better way to visualize or get around these problems of writing in Obsidian? Maybe I should write in Devon think 3 and then link to Obsidian with little summaries. How messy!

It seems like you have two issues.

One is that you’re trying to use a question mark. How are you trying to use the question mark? Can you post a screenshot of the issue?

The second issue is copy-pasting from Obsidian to an email client. I don’t have issues copy-pasting into Gmail. Can you provide a screenshot of the issue? What email client are you using?

Hi @EllenMad.

Obsidian allows question mark character ? inside the content. The only place you cannot use it is on the filename. Can you link to these posts you mention?

As @kbrede says, if you can provide an example of where your cannot use it or the error you get when you try to, we would be able to give better replies.

I appreciate your quick replies. Thank you.

The question mark key does not work in the content.image

I am typing on the back slash key with the shift key down. Nothing is typed. I tried removing the back slash key from the hotkeys. Did not help. I bought a new keyboard that is formatted for English writing instead of Japanese. No change.

Thanks @EllenMad, I see that the “forward slash” / is what gets printed when you press that key with Shift. What gets printed if you do not use Shift?

Can you attach a photo of your keyboard please? And tells us what Operating System and version are you using.

Here I’ve found a list of keyboard layouts. Can you find yours?

2 Likes

When I type shift backslash, I get no typing at all. This only happens in Obsidian. I can type a question mark everywhere else on my Mac.

When I do not use shift, I get a backslash.

I have tried 4 different keyboards and get the same results. Now I am using a Jelly Comb keyboard.

Thank you for finding all the different keyboard formats. image

Computer type:image

Thanks for the detail @EllenMad. Unfortunately I do not know anything about macOS (I use Linux and Windows) so I cannot give further assistance :cry:

I’ve searched about your issue and found this tips:

  • Go to System Preferences → Language & Text → Input Sources, then enable ‘Keyboard & Character Viewer’ in addition the languages that should be available. With this you get an icon in the menu bar. Click it and select ‘Show Keyboard Viewer’ to display an onscreen keyboard. Compare this with your actual keyboard.
  • remove the US keyboard version and install the GB version
  • run the Keyboard Setup Assistant again. Sometimes there is a button for “Change Keyboard Type” visible in System Preferences/Keyboard.

Hope anyone with macOS knowledge gets here!

LINKS:

https://discussions.apple.com/thread/3101017

Does OPT SHIFT ? work?

Might be ALT SHIFT ? on some keyboards.

Option shift brings up an upside down question mark, which is better than nothing. Thanks

Thanks @andrezgz
I have to go to bed now, but I will try your suggestions in the morning. Thank you for looking up Mac information. I should get better at looking for the information myself. I never heard of a GB keyboard before. Maybe that is the problem. Thank you.

1 Like

The problem was “Cycle through panes” was set up with the hot key, / shift . (I changed that setting) I did not see the problem because I did not use it when I had two panes visible.
Under hot keys, In the search bar for the Hot Keys, I could not search for a backslash key because it is in the hot keys and not among the names of hot keys. So, If I had been smarter, I am not sure that I would have found the problem.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.