Underbrace and overbrace not rendering properly

Steps to reproduce

\underbrace{\nabla\times\mathbf{u}}_{\text{curl}} = \overbrace{\nabla\times\mathbf{u}}_{\text{curl}}

Expected result


Actual result



	Obsidian version: v1.1.16
	Installer version: v1.1.9
	Operating system: Windows 10 Home Single Language 10.0.19045
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: light
	Community theme: Minimal v6.2.3
	Snippets enabled: 1
	Restricted mode: off
	Plugins installed: 9
	Plugins enabled: 9
		1: Annotator v0.2.10
		2: Periodic Notes v0.0.17
		3: Dataview v0.5.55
		4: Natural Language Dates v0.6.1
		5: Excalidraw v1.8.22
		6: Quick Latex for Obsidian v2.6.1
		7: Tasks v3.1.0
		8: Advanced Slides v1.20.0
		9: Emoji Shortcodes v2.2.0

	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

It seems to be related to how long the term is. For instance,








This should be an easy fix because I think LaTeX usually adds dashes to make the braces match the size of the term.

The problem persists even if I turn off all community plugins and CSS snippets.

This is indeed an issue that occurs on windows with obsidian. See also:

A current workaround is to find the proper zoom level and or font size.

Hopefully one day this gets fixed by obsidian or mathjax.

1 Like

Well, while I think that would be good to fix this for future versions, it shows up alright on an exported PDF. So this is less concerning for me than I was expecting.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.