Uncontrollable select/deselect in source mode after Android update

Steps to reproduce

  1. Open Obsidian Mobile on Android tablet (Galaxy Tab S6 Lite in my case) after the 2023-02-13 (February 13, 2023) update
  2. Paste the following into a note:
# Obsidian
aliases: []
tags: [2023/02, journal/entry]

# Heading?
- bullet?

## Summary
- **Last time (...):**
- **Today:**
- **Next time (...):**
  1. Enable source mode if not already enabled
  2. Tap the screen once
  3. Observe how everything on the note is uncontrollably selected/deselected


  • Issue does not occur with Live Preview mode, only Source mode
  • Even though there is dataview content in this copy/paste, this bug is replicated in a brand new vault with just this text pasted in
  • Flashing stops if you (a) highlight something or (b) open up the UI, removing focus from the note
  • I tried deleting elements of the copy/paste above to see what the minimum input was to reproduce this issue, and got a new issue where red and blue dots (presumably some kind of invisible character?) were uncontrollably replicating themselves

Expected result

I expect to move my cursor to the point I tap and nothing else.

Actual result

Everything in the note is uncontrollably selected/deselected on loop until focus leaves the note. Additionally, trying to delete contents of the note causes red and white dots to be automatically written to the note, lagging and freezing the app


  • Operating system: Android 13 (samsung SM-P610)
  • Debug info:
	Operating system: android 13 (samsung SM-P610)
	Obsidian version: 1.4.1 (83)
	API version: v1.0.3
	Login status: logged in
	Catalyst license: none
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

Mobile-specific bug reports should be filed here: https://forum.obsidian.md/c/mobile/18

Have you tried to search for this problem there?

Thank you for your response. I did look there and was unable to find other reports of this bug.

I’ve refiled this post as directed: [Bug] Uncontrollable select/deselect in source mode after Android update .