Unable to use mobile iOS app as it continuously keeps loading and reloading

What I’m trying to do

Open Obsidian Mobile iOS App. My vault synchronize with iCloud. The App opens after loading the vault. If I press any button, the app quits and begins to reload. This happens ‘n’ of times, because of which I cannot open or update any notes.
Also the files/folders left pane does not show the file structure. it remains blank.
I have 4000 files and 250 folders with 2.86GB in single vault.

My desktop info:
SYSTEM INFO:
Obsidian version: v1.5.12
Installer version: v1.4.14
Operating system: Darwin Kernel Version 23.4.0: Fri Mar 15 00:12:49 PDT 2024; root:xnu-10063.101.17~1/RELEASE_ARM64_T6020 23.4.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: Minimal v7.5.3
Snippets enabled: 15
Restricted mode: off
Plugins installed: 72
Plugins enabled: 57
Mobile:
iOS version 17.4.1

Things I have tried

I searched in Obsidian Forum , but there is no resolution found so far. Not sure if this is a problem with latest iOS/iCloud Sync.

In earlier versions, I was Able to create/update notes in Mobile.

Most of the forum notes on Mobile remains unresolved and it will be good if someone from Obsidian team can look into it.

2 Likes

I wrote this down many moons ago: Obsidian is not responsible for a solution around iCloud and the sync offered through it is offered because the mobile operating system makes it possible. Otherwise it’s not a good syncing solution.

There are threads where they mention iCloud’s off-loading problems and other forum threads where dissatisfied users and their helpers list possible alternatives (Mobius sync being one of them, or there’s git and a couple of others).

Obsidian has at least a moral responsibility to deliver what they claim.

To sync your notes to your iPhone or iPad, we officially support the following options:

2 Likes

Moral responsibility has nothing to do with technical applications. It’s about iOS and its sandboxing capabilities/limitations.

Where Obsidian – which I’m not affiliated with – can be asked to improve is Obsidian Sync, which people pay for.

My memory is hazy (nor am I inclined to try and wreck my brain for any good cue words with which to search the forum now) on whether anybody using iCloud has found a way to force iCloud files to be available for Obsidian (I seem to remember some talk of it).

I imagine a Siri Shortcut using A-Shell commands could work whereby one – after pickFolder-ing and jump-ing the Obsidian vault folder under iCloud – would use a copy command to copy the full vault anywhere (the copied folder could be deleted straight after with another A-Shell command) on the file system – as a way to make available any offloaded files – then using a final command to open Obsidian.

A variation would be to completely move the full vault temporarily to the onMyIPhone/iPad Obsidian sandbox slot, open vault in Obsidian after a delay (wait command), then after work is done use another command to move all files back to iCloud, but I see this too drastic and could potentially see issues with iCloud not getting on top of itself with thousands of small files.

  • I only mentioned this second method to show the scope of what kind of things are possible.

Some help with how to do some of this can be found here (this was under my old username):

The pickFolder and jump commands are to be used in A-Shell’s terminal first.
No jailbreaking of device is necessary.

says “Obsidian officially supports Obsidian Sync and iCloud Drive”.

When it is officially supported, why should Obsidian not take onus ?

My Main Vault resides in iCloud Drive which I access it in my desktop and in mobile.

Is it incorrect to set it up this way?

I’m using Obsidian Sync and it’s been doing this for days. I’ve noticed if I move files etc. it happens. The only workaround I have found is to update everything on my computer and when I’m done I delete my iOS vault folder and setup the sync again. I’ve noticed it only does this on my phone which has less memory than my iPad.

Understood. However, as I mentioned, my main vault resides in iCloud Drive, which I access in desktop.

I downloaded the Obsidian Mobile iOS app and started sync with the main vault. I was able to create and update notes in the past months.

But now, for last 3 weeks or so, I’m not able to use the mobile app due to its constant loading and reloading which is annoying. So I mainly use Obsidian only in Desktop.

It will be nice to get it working in Mobile too.

Should I delete the iOS app and sync again as you did for Obsidian Synch?

Not incorrect but not fruitful.
Many users have been suffering and were voicing opinions like this seasoned campaigner.

If you are reluctant try my Siri Shortcut suggestion for now, try navigating to your vault in iCloud in the Files app and copy the full vault to a non-iCloud location. When the operation finishes, you can delete the just-copied content as you don’t need these actual copies, this is done as a way to resurrect the zombie files from their undead state (in order to be able to copy something somewhere one needs the local copies to be available).
Then try launching your iCloud vault in Obsidian to see if this was beneficial.

Please, everyone let’s try to remain on topic.

@CluelessProductivity, i think you have a different problem can you please open a separate bug report on the forum and follow the bug report template?

@Vasanth Have you attempted to run obsidian in restricted mode and with the default theme?

1 Like

@WhiteNoise I tried in restricted mode with the default theme. Mobile app Reboots continuously , so behavior is still the same.

@gino_m I copied as suggested to my desktop and then deleted the desktop copy. Mobile app Reboots continuously , and the behavior is still the same.

Can you please post a screen recording showing what is happening?

Keep restricted mode on.

Which phone do you have exactly?

The Phone is iPhone 14 Plus with iOS 17.4.1
I tested as below in the phone:

  • With Restricted Mode off - the App reloads continuously , cannot see the folder structure
  • With Restricted Mode On - the App is stable and I can see the folder structure

Is any of the plugins causing the issue? how to identify?

You have a lot of plugins. There is one called “Divide and Conquer” that helps test plugins in groups. I’ve never used it, and I don’t know how it works on mobile.

The other first step you can try if you didn’t yet is to update all your plugins (maybe on a synced computer where you can still load Obsidian).

Ok, so this has nothing to do with iCloud.

From the way you describe this problem, it looks like some plugin is causing obsidian to run out of memory and the OS kills it. You can use Divide and Conquer method, and you can begin with the big ones, like dataview or omnisearch.

Yes, the divide and conquer helped. So the issue is with plugin, as I disable most of them, as I was experimenting with some of them. This was causing a huge memory drain and causing iOS to kill those high processor demands.
I did not touch dataview as this is amongst my most used one. Omnisearch was spared.

I could get the files structure comeback in my mobile, which was showing a blank screen earlier. I would be careful not to overload the plugin use.
thanks for your cues @rigmarole and @WhiteNoise

1 Like