Unable to Use Cloudflare Custom Domain With Publish

In the process of moving my domain to Cloudflare to then use with Obsidian Publish, I’ve run into issues with the DNS settings.

I’ve setup CNAME records for my URL (and “www” subdomain) as per Obsidian docs. The former worked for a little bit, but in my efforts to get the latter working, now neither work.

I now get an Error 1014 (“CNAME Cross-User Banned”) on both.

I contacted Cloudflare support and they said they “generally [do] not allow customers to use CNAME records to point from their domain to a domain on another Cloudflare account.”

Naturally I’m a bit confused, as that seems like exactly what Obsidian Publish with Cloudflare is supposed to do.

They suggested I contact the owners of this other account I’m seeking to point to (Obsidian) and ask them to contact them (Cloudflare) in return.

They say it’s a potential security issue (it could “expose your origin server IP address”) and that they need Obsidian to say it’s okay to allow others to point to their sites with CNAMEs, then they’ll “make the change” to allow it.

I’m normally pretty tech savvy, but this is over my head. Any assistance or clarification would be greatly appreciated.

I’m facing the same issue.

can you post a screenshot of you configuration on cloudflare?

You need to use publish-main.obsidian.md instead of publish.obsidian.md as your CNAME value. This is because publish-main.obsidian.md is the raw (non-cloudflared) DNS entry and publish.obsidian.md is the cloudflare-enabled DNS entry.

Thank you. It is working now. :clap:

Thanks, that URL worked for me, too!

However, I’m still unable to get the “www” subdomain to resolve with the same URL (I get a blank page in Firefox or Safari, or a 404 error in Chrome). I’m using another CNAME (as shown in image); do I need to use an A record instead? If so, what IP address do I point it to?

The problem you faced can be resolved, If you redirect www record to your root domain instead of publish-main.obsidian.md . (I assume that you register your root domain in the settings of Obsidian Publish).

Gotcha. Though that doesn’t seem to have resolved things. Still getting blank page at “www” subdomain. (And you’re right, I have Obsidian Publish pointing at the root domain).

You’ll want to create a page rule that redirects www to non www like this:

Adding such a rule made it work in Firefox (my main browser) on my mac, but it doesn’t appear to work anywhere else (chrome, safari, or firefox on iOS).

All works now! Only remaining step was to change the CNAME record for “www” back to “publish-main.obsidian.md” then wait an hour for changes to propagate.

Many thanks to @Licat for the help and encouragement to be patient!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.