Unable to Search for Uploaded .txt Files (Solved)

In Obsidian 1.1.9 on Windows 10 Home, I created an ‘Assets’ folder and uploaded PDF and .txt files using drag/drop. The PDFs displayed in the Assets folder, but the .txt files did not. When I tried to embed the .txt files using markdown, Obsidian could not find them. Checking the actual Windows Assets folder showed that the .txt files existed. Dragging and dropping files directly in a note worked, but those files could not subsequently be searched from the same or other notes. I was able to reproduce this issue on Android.

The solution was opening Settings / Files & Links, then enabling “Detect all file extensions”.

Thanks for sharing your solutions! A better way than posting in Help with (solved) in the title is to either:

  • post in Share & Showcase
  • Post the problem in Help and then post the solution as a reply, and mark the reply as the solution (the checkbox button at the bottom of the reply, may be hidden behind 3 dots).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.