Unable to Open Obsidian


What I’m trying to do

ever since the update 1.4.16, i’m unable to reopen Obsidian on my mac.

Things I have tried

maybe it has nothing to do w the update. I managed to turn off community plugins to restricted mode, and the issue is solved.

However, I have many plugins and don’t know a way to turn on each plugin in to see which is the one causing the fault, without obsidian turning white and shutting down.

any advice on how to resolve this is much appreciated

The file that tracks which plugins are activated is:


You could close Obsidian, and then carefully edit this, to remove all or some of the plugins. Your settings should stay intact. This is equivalent to untoggling the “activated” buttons on the plugins.

By “carefully”, I mean:

  1. Backup your whole vault first, just in case.

  2. Watch the JSON syntax. The last entry in a JSON list has no trailing comma. Or you can just move that file out of the directory and Obsidian will make a fresh one for you with just:


Then you could install “Divide and Conquer” plugin to help manage the testing. Or you could just hand-edit the list yourself (when Obsidian is closed), and choose half the list to test at a time.

OR, easier: Deactivate all the plugins by moving the file out. Then open Obsidian and update all your plugins. Then put the file back to activate them all again. Maybe all you need is a plugin update to fix the issue.


Hi rigmarole,

Man, you are a life saver!

I copied out the plugins, and pasted back those thst needed configurations (as I didn’t want to lose them), and then manually reinstalled all my other plugins. Fingers crossed… it works now!

the reason I manually reinstalled the majority of the plugins:
I previously tried to copy and paste back all the plugins from the folder, but a blank white window appeared once again.

I am super thankful for your help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.