Unable to open Obsidian files

I upgraded to a new Windows and I am now unable to open the .md files I had saved from my previous version of Windows.

What I’m trying to do

I’m trying to open Obsidian files I had saved. I downloaded the software again and I’m clicking on my old vaults, but it’s like Obsidian doesn’t recognize those files anymore

Things I have tried

I am able to open the files in notes, so I know that the content of the files is there. I tried opening from the folder and it keeps on reinstalling Obsidian each time. If I try to open the existing vault from Obsidian, it’s like it doesn’t recognize its own old files

I’ve seen people experience similar issues that have to do with versionning. I don’t think it’s the same situation here.
I want to cry thinking I may have lost months and months of daily notes. Help me please!

Can you elaborate on this? What do you mean it keeps on reinstalling Obsidian?

I can’t imagine what that means. Can you maybe show some screenshots or screen recording of what’s going on?

Can you specifically list (or show) the steps you are doing? When you say “it doesn’t recognize its own old files”, what specifically do you mean? What happens? What does it look like?

If you can still open the files, you haven’t lost anything.

More questions:

  • How did you move your files from one Windows installation to the other?
  • Are these files stored in a cloud tool? If so, are they downloaded and available offline?
  • When you moved your vault to the new Windows, did you also save the hidden .obsidian folder?

Thank you for your reply.

Here are some screenshots:

Every time I click on an .md file, I get the same messages. If you see the note that opens, it’s not the same one I clicked on. It’s just always an empty daily note that seems to open.

I had saved all of my files on my OneDrive. They are downloaded and available offline.

Yes, I do still have the hidden .obsidian folder

It looks like you have set Obsidian as the default app to open those files from Windows Explorer, but Obsidian can’t open files that way.

You need to open Obsidian and add your vault folder as a vault. After that you’ll be able to open the files from within Obsidian.

I also recommend changing the default app for those files so you can open them in a separate text editor if you want to.


Thank you, it worked!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.