Unable to log in to site or app even after resetting password

I have a new account at the supporter tier but I am unable to log in to it either through the app or the obsidian.md site. I am trying to log in to the app to receive the new insider build since I work heavily with PDFs.

Note: I am aware there are different accounts for the forum and the main site. I am using the login credentials that were accepted by the site during account setup, but are rejected immediately after being accepted during setup.

Steps to reproduce

  • Create account on obsidian.md using my email and a 20-character randomly generated complex password
  • Store password in password manager
  • Account setup is accepted and I appear to be logged in
  • Log out and attempt to log back in through the app or site using the credentials in the password manager

Expected result

Site and app allow me to log in.

Actual result

Receive message: Login failed, please double check your email and password.

Extra twist: When I use the forgot password feature on the site it emailed me a link to reset my password, though I had to use that feature twice to eventually get a single reset email. Additionally, when I reset the password I again generated a completely new random 20-character password and stored it in the password manager for obsidian.md. I then clicked the entry for obsidian.md in the password manager and it auto-filled the new password field. I then clicked the button on the site to set that as my new password. The site accepted this and logged me in. I then logged out and tried to log back in using the exact same password that was just accepted, clicking the entry for obsidian.md in the password manager exactly as I had a moment before, and instead I received the same error message and it refused to log me in.


  • Operating system: MacOS 10.15.7
  • Obsidian version: 0.10.7

Additional information

Nothing at this time. Thanks.

if instead of letting the password manager enter the password, you manually copy/paste username and password, does it work?

I actually have a 20char random pass and I use LastPass. I can’t repro.

ALso is it possible that your password manager is getting confused between the forum and the website and is autofilling the forum password to the main site?

I also tried manual copy/paste and it did not work. Tried it again just now and confirmed it is not working. They are completely separate entries in the PWM and tied to unique URLs, one for obsidian.md/account and the other for forum.obsidian.md.

In case it is an issue, the password contains the following special characters:

  • ^
  • *
  • @
  • #

In some cases more than once. The remaining characters are alphanumeric.

I am currently performing multiple resets and experimenting. It allowed me to log in with a similar length complex password I created. Wondering if the character choice is causing an issue somehow.


Your login form requires the email address to be case sensitive.

I just confirmed it. When manually typing in my email in the field it is automatically given an initial cap by my OS. This is virtually never a problem. But it is lower case in the password manager. And so the login form rejects it.

Case sensitivity in the part before the @ is technically in compliance with the RFC but virtually nobody in practice actually enforces it. Recommend you consider switching to the de facto industry standard. Example discussion with rationale: https://blog.teknkl.com/email-addresses-case-sensitive-but-anyway/

1 Like

I have exactly the same situation and can neither log in nor request a new password.
Now I’m afraid I misspelled the email address when I registered. Is there any way to find out?

You can email [email protected] or send a DM to @Silver on our Discord server.

1 Like

Solved. Very fast and kind support, thank you very much!

1 Like

had the same issue with capitalised first letter of my email… thanks for the thread or would have caused me lots of heartache.

Second the industry standard for email