Unable to Interact with Storage Permissions Prompt in Obsidian

Steps to reproduce

On GrapheneOS I recently installed Obsidian from the Play store, and have found that when trying to grant storage permissions when prompted by the app, I am unable to interact with the permissions pop up. My goal is to use storage scopes, however none of the three options work.

I enabled app compatibility, this made no difference.

I tried using a Bluetooth mouse as an input, and it also could not interact with the pop up despite the cursor changing to an index finger.

Did you follow the troubleshooting guide?


Expected result

To be able to grant storage permissions.

Actual result

Unable to grant any storage permissions, rendering the app unusable.



Additional information

I tried removing permissions from other applications such that they would request them when loaded up, and for each of these it works fine. This leads me to believe it may be more of an Obsidian issue, but I can’t imagine how the application could have an impact on the OS popup.

Phone: Pixel 4a 5G
Version: 14
Build: UP1A.231105.001.2023111500