Unable to drag and drop picture

I am on windows.

I am trying to drag and drop a .jpg from file explorer, but it is not working.
Is that a bug?

where are you dropping? On an open document?

Yes indeed, or even onto the file explorer.
In either case, the mouse gets replaced with an X circle. I tried to take a screenshot, but for some reason, it doesn’t save the state of the mouse!

it should work when you drag and drop on an open document. If it doesn’t, can you make a short video?
With loop or something similar?

Here we go. I created a new blank project, so the default settings are used.
Bug Demo

Thanks, never seen that shape of the mouse in windows.

Me neither. is it something that has to do with my windows in particular, or a windows problem in general?

I don’t know if you have some program running that interferes with drag and drop? You can try to stop all the background programs/utilities you have and see what happens.

So i ran a few cleanup based on this and that seemed to solve the problem because I didn’t do anything other than this.

Anyway, looks good now! Thx for the support @WhiteNoise

This drag and drop function does not work for me on a new Mac Catalina. My system work perfectly fine and I can drag and drop pictures in two other MD editors including Typora and Joplin. However, this does not work in the latest version of Obsidian.

Thanks

This will be the same answer as before. Can you please upload a gif or video showing the problem?

I’m on MacOS Catalina, and it works for me.

Are you dragging into Edit Mode (should work) or Preview Mode? (this will not work!)

Hi, I am dragging to the edit mode but it still not working. Copy and paste a picture does work, though!
Thanks

Where are you dragging from?

Can you post a gif or video? Otherwise, there isn’t much that can be done. It works fine on my Mac.