Unable to create new vault on SD card

Things I have tried

I tried to create a new vault on my SD card.

I am running Android 10 on a Samsung Galaxy Note 10+
Permissions manager reports Obsidian has Microphone and Storage permissions allowed.
Somewhere I read to first make a folder on the SD card. I have tried that.

When I try to create the vault on the SD card I do the following:

  • Select the SD card
  • Then select the folder on the card (“dentemp” an existing folder)
  • System asks me to allow access to ‘DENTEMP’ in 'SD’card. I click “allow” (the actual directory is “dentemp” in lower case).
  • a box at the bottom of the screen briefly shows “content://com.android.externalstorage.documents/tree/3732-3830%3Adentemp/documents/3732-3830%3Adentem”
  • The vault location now says "Your vault will be placed in “/storage/3732-3830/dentemp”
  • I click Create and get the following error:
    • “Failed to create vault. Unable to create directory, for unknown reason”

I am new but not a complete idiot. I have searched the forum but only see older posts related to this which leads me to think it is something particular to my setup.

Any pointers would be appreciated.


1 Like

I also have the same problem.

I’ve seen it a few times on forums that have solved it, and I’ve tried following it, but it doesn’t work.
(set permissions, etc.)

Same problem.

  • Obsidian version: 1.1.0
  • Android version: 10
  • Type of external storage: microsd card? external usb drive?: micro SD card
  • what error do you get?: “Failed to create vault. Unable to create directory, unknown reason.”
  • A screenshot of the error. If there is a path in the error, make you the screenshot includes the path.:

Extremely annoying. The very reason I wanted to switch to Obsidian was to use it offline on mobile, but I can’t even create the basic vault for “unknown reasons”.

I am now using 1.1.1 (49) and this is now working.

I cannot create a vault in the root of my SD card which I’d like to do but if I create a folder in the root of the SD card, say “Vaults” then I can create vaults within it and they work fine.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.