Unable to add Properties to existing notes or new files that have no prior properties Ver 1.4.9

Before opening a new bug report, please search the forum for duplicates and follow the Troubleshooting Guide.

  • We only consider bugs that are reproducible in the sandbox vault or a vault with no third-party plugins/no css snippets/default theme.
  • For Linux, we only accept bug reports that are reproducible with our Appimage package under Gnome or KDE.
  • Developer issues with the API should go here

Once you’ve done the above, delete everything above this line.

Steps to reproduce

  1. Since I was updated to Ver 1.4.9 today, I cannot create any properties in notes that are:
  • Existed prior to the version upgrade but had no properties or tags
  • Any new notes that I create

I tried all methods and nothing is working.

Jeff

Did you follow the troubleshooting guide? [Y/N]

Expected result

Actual result

Environment


Additional information

Hi, thanks for the report. This issue is being tracked and will be fixed for the next release. Sorry about that!

What have you tried exactly?

We are aware that it entering properties from the properties sidebar is not working, but the rest works.

I’ve tried it from the three dots, from CMD-P, from the side panel, and in edit mode using —. none work. I can tell that when I type the — the first visible line number changes from 1 to 4, but that’s the only evidence of anything happening. I know that before, when I selected properties in the side panel I had a + New property button, but not now.

As a workaround I can create a new note, insert a template (that had properties) and then delete all the template stuff and put what I need in the note.

Oh, and I also tried the CMD-; That doesn’t work either.

Thanks,
jm

Are your properties visible in the editor or did you hide them use source mode?

Does it work in the sandbox vault?

I don’t use the Sandbox, as I’m not a developer type, though I’m becoming more of one to keep tweaking Obsidian. Yes, I did find that if I go into the Editor settings and change “Properties in Document” to visible, I can now add a property. As soon as I do that, then all the other ways of dealing with properties become available (CMC-;, more options, side panel, CMD-P) are all functional.

Seems the issue is known and will be fixed shortly, but for the record: the Sandbox isn’t for developing or anything. It’s just a vault that resets to play around in with the default settings, no community theme, no CSS snippets, and no community plugins.

It has the added bonus of being an easy way to see if an issue you have in your own vault also exists there or not.

1 Like

Thanks. Yes, I’m famiilar with sandbox, but its more a matter of time that I don’t have the luxury of trying things out. Running my business takes most of my time. I’d love to try more things. I’m still wrapping my head around Dataview. :wink:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.