UI rendering is inconsistent in I3 tiling window manager

I’ve been running into an issue where Obsidian does not redraw/update properly when running under the i3 tiling window manager on Linux. I don’t know if this is an issue inherent to any tiling window manager or just i3.

If the Obsidian window is resized by i3, the UI doesn’t update properly. If I switch the window to float mode and manually drag & resize the window it updates, but further interaction with the window doesn’t actually redraw any of the UI.

Curious if there’s any other i3/tiling WM users who have experienced the same thing?

Steps to reproduce

  1. Start Obsidian on a desktop with other windows
  2. Resize the Obsidian window

Expected result

The Obsidian window should redraw correctly.

Actual result

The Obsidian window does not redraw and does not update when interacted with.


  • Operating system: Ubuntu 18.04, i3 4.18.2
  • Obsidian version: 0.10.13

Additional information

This is interesting, I’m also on Ubuntu 18.04 using i3, but I can’t reproduce this issue. What compositor are you using?

That is interesting! I’m currently using picom but I’m not tied to it, I will try a few others.

It’s definitely something compositor related. If I stop picom entirely the UI rendering is fixed. I’ve tried various compositors (picom, compton, xcompmgr, unagi) and all seem to have the same manner of rendering issues out of the box for me. I tried passing the no-use-damage option in picom’s config which fixed a lot of the rendering issues, but also drove my system load up while using Obsidian.

I at least have a direction to start poking in now, thank you!

1 Like

… and turning on vsync in the picom config solved my resizing problem. The Obsidian window itself disappears if I switch back and forth between desktops, but at least it renders properly after I resize it.

Glad the resizing is working! There’s definitely something funny going on though. For what is worth, I’m using compton (a bit old!) and no windows disappear for me when switching desktops.

I am having similar issues (and maybe a few extra) in Kubuntu with, I assume, KWin:
Ubuntu 18.04.5 LTS with KDE Plasma 5.12.9 (Qt 5.9.5)

I don’t tinker a lot with my system and I don’t know a lot about windows managers, so please let me know if there’s anything else I can do to provide relevant information. I am having issues similar to what’s described above, but not exactly the same. I didn’t know whether it would be better to start a new thread.

In my case, it’s not that the window partially redraws or looks disjointed, but rather, the entire window does not update.

Sometimes I type and I don’t see my text appear without a few seconds’ delay; other times, the text doesn’t appear until I move the window with my cursor or resize it. Restarting the application temporarily clears up this state, but eventually, after minimizing and maximizing from the task bar some number of times, it becomes unresponsive again.

The main thing that is persistent and different from what it described by jorsk is that when I restore the application from the taskbar by single-clicking on it, I’m not able to resize it, because there’s nothing drawn and no window chrome to resize. When I minimize the Obsidian window, I can’t get it back at all unless I right click on the task bar and manually click ‘Maximize’, although when I simply click on the task bar there is a strange animation as if something is being expanded, but it doesn’t actually draw the Obsidian window. I tried to take a video, but the task bar wasn’t included – all that’s happening is that I’m either single clicking on the task bar when it doesn’t expand, or right clicking when it opens the dialogue.

not updating_compressed.zip (3.2 MB)

At the end of this video, although I’m typing, it’s not updating anything.

EDITED: As of this morning, VS Code is doing the same thing. I suspect this problem is not specific to Obsidian.