Typing in Tibetan slightly broken

Hello everyone,

I have been trying to write in Tibetan lately and the observed behavior in Obsidian baffles me. System specifications : MacBook Air, High Sierra, azerty keyboard. Vowels on top of consonants are doing fine : ལེ, but I am struggling with stacks of consonants, like this : སྐྱ.

  1. In every single application where I have tried to type Tibetan (WhatsApp, Skype, Chrome, OpenOffice, Word, you name it) over the last six months, the “Tibetan Otani” Input Source has always worked the very same way :

    1. You press the key of the consonant that will end on top of the stack, for instance ཀ.
    2. Then a key that tells the system that the next consonant should be placed below the previous one. This binding symbol looks like this : ྄
    3. Then the key of the consonant you want below the stack under construction.
    4. Then Space, which prints the syllable separator : ་
    5. And you end up with : ཀྲ་ for instance.

    However in Obsidian, if you try step 2 after step 1, it won’t work. You need to either press Escape, or Space and delete the syllable separator, or left arrow and then come back to the position just in front of your initial consonant for the merging to occur (notice that when first typed, the initial consonant is thickly underlined ; until this glowing line vanishes, you can’t achieve the merging). Otherwise you get this dismembered mess : ཀ྄ྲ.

  2. The “Tibetan Wylie” Input Source also fails me. The procedure here is simpler : simply type your two consonants then the syllable separator and everywhere on your computer you should get something like the following result, ལྲ་ In Obsidian the second consonant you’ve typed is repeated between the stack and the syllable separator : ལྒྒ་

I have attempted to change the fonts (by downloading community themes and replacing every single font-family property of the CSS file by “Times New Roman”, but I’m unsure about the outcome). I believe this is not the issue. I might be wrong.

Thanks in advance for your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.