Typing "|" in note picker does not insert display text in internal link

Steps to reproduce

  1. Start entering a new internal link: [[Note name…]].
  2. Select a matching note with the arrows.
  3. Type “|” so as to validate the selected note and start adding custom text (like # does for headers, and like the message “Type | to change display text” seems to indicate).

Did you follow the troubleshooting guide? Y

Expected result

I was expecting the selected note name to be automatically completed, and | to be added afterwards, with the cursor ready to enter some display text. This is what # does (as is also indicated in the Note selector).

Actual result

Instead, | is displayed as if it was part of the note name, even though it apparently [cannot be part of a note name](Improve UX for adding custom display text to an internal link - #3 by dsteinbock.


Obsidian version: v1.3.5
Installer version: v1.3.5
Operating system: Darwin Kernel Version 22.5.0: Thu Jun 8 22:22:19 PDT 2023; root:xnu-8796.121.3~7/RELEASE_ARM64_T8103 22.5.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

this is intentional and has been asked several times on the forum.

I failed to find anything. Do you have any pointer? I’m curious why the note selection dialog still indicates that one can type # (correct) or | (incorrect).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.