Turning off Automatic updates is not working

Things I have tried

I googled and searched the forum, didn’t find anything.

What I’m trying to do

So I hated current version of Obsidian, 15.6, and installed earlier version, 14.15. Right away, I turned off Automatic updates. But after some time, it updated to current version anyway. Is this a bug? How do I permanently disable auto updates?

Btw, I deleted “C:\Users\Home\AppData\Roaming\obsidian” folder before I reinstalled 14.15.