Turn off the IME at the same time as returning to normal mode with the ESC/Ctrl+[/Ctrl+C key

Since I use VIM, I use two types of mode switching. One is VIM and the other is IME.

1. Use case or problem

Often forget to turn off IME, even though it is obvious that it is not used in normal mode. My hands are often confused.

2. Proposed solution

Turn off the IME at the same time as returning to normal mode with the ESC/Ctrl+[/Ctrl+C key.

In GVIM, I use im_control.vim.

3. Current workaround (optional)

4. Related feature requests (optional)

5. Other

Could this be solved with “vimrc support”?
I would hope to know what you were setting up if you could solve it?

I have resolved this with Google IME.

the part of key bind configuration.

DirectInput	Escape	CancelAndIMEOff
Precomposition	Escape	CancelAndIMEOff
Composition	Escape	CancelAndIMEOff
Conversion	Escape	CancelAndIMEOff
Suggestion	Escape	CancelAndIMEOff
Prediction	Escape	CancelAndIMEOff
2 Likes

I had the same issue. Thanks to you, I was able to solve the issue.