Trouble with typing in notes

After using Obsidian for a perhaps 30 minutes, I am unable to edit notes. The cause seems to be plugins. I have eliminated all plugins.

Several days ago, I was not having this problem. As is usual, I clicked off all plugins. Closed Obsidian. Reinstalled Obsidian. The editing worked. Then added the safe plugins that had shown no signs of troubles before this editing problem began. (Snowwhite, sliding panels, Note Refractor, Emoji tool bar) Soon, I could not edit notes.

I tried restarting my computer pressing P R keys with alt control and command ?? Sadly, the problem with editing notes returned after I installed what had been the safe good plugins.

I thought that maybe my Japanese language settings were causing the problem. So, I tried to turn off Japanese. In the Apple system preferences, I turned off Japanese, but the Japanese key switcher icon is still in my menu bar and it still works. I have shut down my computer again but it is still in the menu.

Maybe I am having this problem because of Karabiner which runs my cheap keyboard. I checked the preferences called Karabiner elements. Nothing there about the Japanese key. (The cheap keyboard has a key that turns on Japanese text.) I can use my iPad for Japanese. So, if Japanese is the problem, I don’t need it.

Also, my Mac is a late 2012 iMac with 8 gb RAM running Catalina. I took off all high CPU programs on my computer except DT3 and professional data analysis programs that I need for my work. A video editor, powerpoint. The point is, I limit my usage to 2 of these programs at any time and still have these problems with Obsidian. What could be the issue?

Are you switching your notes to the Preview mode? Notes can only be edited in Edit mode. (cmd/ctrl+e is the default hotkey, I believe. You can also set the default for how notes open in preferences.)

I have it set to Edit mode. I never look at the Preview mode.

I think I have to give up. Obsidian can not be used on my old 2012 Mac with Catalina on it. Maybe I have to get rid of the Catalina. Will it work on a High Sierra Mac? Is there some way to get .md documents from an iPad or iPhone to a Windows 10 machine?

Can you post a screen recording of what is happening, It’s hard to understand from your description.

Obsidian works fine on Catalina. As for your old 2012 computer, I couldn’t guess if that is the problem or not.

and still have these problems with Obsidian.

Multiple times, you have said you have a problem editing notes. But you didn’t really describe what the problem is. Is the app unresponsive or freezing? Crashing? Can you please try to describe what’s actually happening?

Specific keys are not working. Now delete won’t work. The keys that don’t work keep changing but they are usually those highly functional keys and not letters of the alphabet.

It’s just those keys don’t work in obsidian. They work in other programs.

I change the Theme of obsidian, and for a while it was working OK. For a while I mean like couple of hours. I added Andy’s sliding panels and the problem returned. I didn’t tinker with it anymore because I’ve had this problem exactly in this way before.

Is vim mode enabled? There’s a switch for it in preferences.

1 Like

As soon as I add a Plug-in, I have trouble. I take out all the plug-ins,But in the sitting area, plug in still are there. I’m talking about the column on the bottom left side. The templates plug-in and one other are still listed there. Furthermore when I reinstall Obsidian, those two plug-ins are listed in that left column. After I close the settings panel the icons for templates, organizing desktop windows remain.Also those functionalities remain. I can Make multiple windows, arrange my desktop, and use templates that I’ve made before. It is is if I am not fully erasing the original problematic version of obsidian.

I have never touched the VIM Plug-in and I don’t know anything about it.

I have a keyboard that uses a program to work. It is called Karabiner-elements. But my bluetooth keyboard does not work either. Their problems are the same.

You have probably turned on vim mode.

Some people have accidentally enabled it in the past. It is the last setting in the Editor preferences—you should double-check if it’s on when these key issues occur.

In general: to disable all plugins, you have to disable every option in the Core plugins and Community plugins preferences.

When you uninstall Obsidian the app, you do not necessarily reset your vault(s). Obsidian works by creating a “Vault” on a folder and its subfolders. Every time you create a new vault (e.g., the first time you run Obsidian, then manually later on), you create a new instance of Obsidian with its own settings, including plugins and themes.

Deleting Obsidian the app does not remove these settings, plugins, or themes on from those instances.

If you want to truly reset a vault, you have to go to the root folder of the vault. The easiest way of doing this would be to do the following:

  1. Open the vault you want to reset (if you have only one vault, open that vault);
  2. Right-click on a top-level file or folder in the file explorer and select “Show in system explorer”;
  3. Close the vault (or quit Obsidian);
  4. In the system file explorer that opened (i.e., Finder on macOS, File Explorer on Windows, probably something weird on Linux idk), make sure you can see hidden files. (On macOS, press cmd+shift+.; not sure what the command is on Windows/Linux).
  5. With hidden files visible, delete the .obsidian folder you see in that system file explorer window.

The instance of Obsidian operating on that folder and its files/subfolders is now gone. You can create a new vault on the same folder with default settings by selecting “Open folder as vault” in Obsidian’s vault switcher again.

1 Like

Thank you for all your instructions. I had enable VIM checked in the editor of my Obsidian. As soon as I unchecked that, my problems disappeared. What a relief. Thank you. You were right from the beginning.

I am keeping your instruction for disabling all plug ins. I hope to never have to use your notes.

1 Like