Transparent text in exported pdf when using dark system color scheme

Steps to reproduce

  1. Use Gnome DE and choose Style->Dark under appearance settings.
  2. Go to Settings->Appearance->Base color scheme and set it to “Adapt to system”.
  3. For the “Start here” document first shown when opening the sandbox vault, choose “Export to pdf”.
  4. Choose default options, save anywhere.
  5. Open pdf.

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

Non-transparent text in the generated pdf.

Actual result

The text is transparent, i.e white on white background.

Environment

SYSTEM INFO:
Obsidian version: v1.4.12
Installer version: v1.3.5
Operating system: #1 SMP PREEMPT_DYNAMIC Thu Sep 7 00:25:01 UTC 2023 6.4.15-200.fc38.x86_64
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none


Additional information

The problem only appears when the theme is “adapt to system theme” and my system theme is dark (on GNOME, Fedora 38). If I pick the dark theme in Obsidian, the issue disappears.

There was a similar issue named " How to set basic black text on white background colors for PDF export when using a dark theme?" [How to set basic black text on white background colors for PDF export when using a dark theme?] but that was for the manual dark theme (which works in my case). Not sure if this is expected behaviour, if so, let me know.

2 Likes

I am experiencing the same, here’s the info from the bug report I was making when I found this existing one.

Environment

SYSTEM INFO:
Obsidian version: v1.4.14
Installer version: v1.4.13
Operating system: #1 SMP PREEMPT_DYNAMIC Sun Sep 24 15:52:44 UTC 2023 6.5.5-200.fc38.x86_64
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

Note this debug info was taken before I found out that it was ‘Adapt to System’, so the theme info might be confusing.


Additional information

Here is a screen recording showing the issue:
https://file.io/waqzDv5Bs9sL

I’m experiencing this on the latest version v1.5.3. Is there a suggested work around? I would like to not need to switch my theme back and forth to generate the PDF.

Originally I had the Obsidian theme set to Adapt to System, with it explicitly set to Dark this functions as expected.

I am having the same issue. Interestingly, toggling ‘dark mode’ off an on solved the issue for me (Ubuntu 22.10, Gnome).

Are you all on linux?
I wonder if this is just another manifestation of this

Using dark as the base color scheme seems to solve the problem


4 Likes

Thank you so much! I really needed to print my notes for class. This works great.

Same problem here, and like you said, I use the Linux (PopOS/GNOME).

Using the solution propose by ihab_dahel solve the problem.

Same issue 100% reproduced on my Ubuntu 22.04 laptop.

Same issue reproduced as of today on snap installed obsidian version 1.5.8 on ubuntu 23.10.
The issue goes away by switching from use system default to dark under settings → apperances → base color scheme.

did you download and reinstall the snap from our website?