Toolbar on mobile keeps resetting

Before opening a new bug report, please search the forum for duplicates and follow the Troubleshooting Guide.

  • We only consider bugs that are reproducible in the sandbox vault or a vault with no third-party plugins/no css snippets/default theme.
  • For Linux, we only accept bug reports that are reproducible with our Appimage package under Gnome or KDE.
  • Developer issues with the API should go here
  • Themes and Custom CSS issues should go here

Once you’ve done the above, delete everything above this line.

Steps to reproduce

  • customize tool bar
  • kill app or come back to app later(basically whatever triggeres the loading plugins screen)
  • open keyboard and toolbar is reset back to default

Did you follow the troubleshooting guide? [Y/N] Y

Yes(sandbox mode appears to be unavailable on mobile, created a new default vault instead to confirm behavior

Expected result

To be able to customize my toolbar to have my most used actions readily available

Actual result

toolbar resets and gives me default toolbar that has several actions i dont use daily


Operating system: ios 17.5 (Apple iPhone16,1)
Obsidian version: 1.5.12 (134)
API version: v1.5.12
Login status: logged in
Catalyst license: insider
Live preview: on
Base theme: light
Community theme: Prism v3.5.0
Snippets enabled: 2
Restricted mode: off
Plugins installed: 26
Plugins enabled: 13
1: Periodic Notes v0.0.17
2: Style Settings v1.0.8
3: Templater v2.2.3
4: Persistent Graph v0.1.5
5: List Callouts v1.2.7
6: File Color v1.1.0
7: Vault Statistics v0.1.3
8: Auto Link Title v1.5.4
9: TimeStamper v1.3.0
10: Natural Language Dates v0.6.2
11: Typing speed v1.2.1
12: Daily Note Navbar v0.1.2
13: Settings Search v1.3.10

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I’m not able to reproduce this. What are you using to sync your vault?

im using the built in obsidian sync.

Is your vault in your computer’s default documents folder? Sometimes that folder is set by default to be controlled by OneDrive (on Windows) or iCloud (on Mac), and using 2 sync services on the same files can cause confusion, duplication, or data loss.