Toggle sidebar stops working after one use

Steps to reproduce

  1. Open Obsidian
  2. Toggle left sidebar using keyboard shortcut
  3. Toggle left sidebar using keyboard shortcut again

Did you follow the troubleshooting guide?



Expected result

Toggle left sidebar

Actual result

Nothing. The toggle sidebar function works once, and then does nothing afterwards.


Operating system: android 11 (ONYX TabUltra)
Obsidian version: 1.5.8 (126)
API version: v1.5.8
Login status: not logged in
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

Edit: the left sidebar stops working, regardless of whether I use the keyboard shortcut, or the downward swipe, or a hotkey, or press the little button. The right sidebar stops working only with the keyboard shortcut, but often (not always) works when I press the button.

1 Like

I can’t reproduce this.

Thanks for checking.

It’s interesting that the sidebars were working perfectly before I updated. Would you recommend going back to a previous install (if that is even possible)?

Here is a youtube video demonstrating the issue. I open the app, and then close the sidebars using keyboard shortcuts. The keyboard shortcuts stop working. Then I try to open the left sidebar using the downward swipe – it does nothing. Then I successfully open and close the right sidebar. Then I close the app and demonstrate again.

What I’m trying to do

My left sidebar won’t reopen after I close it, as I noted in this bug report. I ordinarily use the left sidebar to access my files. I am trying to find a way to access my files without using the left sidebar. Ideally, I would like to move the file viewer to the right sidebar. Does anyone know if this is possible? If it is not possible, are there other ways of accessing my files that anyone can suggest?

Things I have tried

  • Close and reopen Obsidian every time I need to access the left sidebar
  • Access files via the “quick switcher” (not ideal for browsing through the files)

Swipe down to use the command palette:

  • Does the file explorer pane show if you run the command, “Files: Show file explorer”?
  • Does the sidebar toggle if you use the command, “Toggle left sidebar”?

From your description it sounds like you only tested the hotkey. You said swipe down, but I’m not sure if you tested the commands.

What hotkey did you set, by the way? Have you tested a different hotkey to see if that specific hotkey is causing an issue?

(edit: I merged your topics. No need to double post.)

Hi, thanks for your post.

  • the file explorer pane does not show if I run the “show file explorer” command from the command palette
  • the sidebar does not toggle if I use the command “toggle left sidebar” (via a hotkey – I use ctrl+alt+left-arrow, nor if I select it via the command palette; also, changing the hotkey does not fix it)
  • the left sidebar does not appear if I click on the left sidebar icon, but the right one does (puzzlingly, the right sidebar works if I click on its icon, while not working via the shortcut)
  • the original bug report only mentions the hotkey, but I have tried other ways of accessing the sidebar; I added more information in the “additional information”, and I posted a youtube video demonstrating the failure of the downward swipe, and the “toggle left sidebar” command palette method

I do not consider it a double post. One topic reports the bug. The bug may never get resolved. In which case, it seems legitimate for me to want to ask the community for help with using Obsidian with this restricted functionality. Having said that, I appreciate you exploring my bug report.

1 Like

Ah yes, sorry I missed that part of your video. I was on a phone when I first watched it.

@WhiteNoise I am able to reproduce this on iPadOS.

I opened up the app and set the hotkeys, and it was working fine. I didn’t check the version.

Then I came to start typing this post. I opened up my iPad again and noticed the app was updating, with a loading circle. Now it’s 1.5.8 (126) - Fresh vault, no themes, no plugins.

And the hotkey and command no longer work. Once the left sidebar closes, it doesn’t open again.

1 Like

This will be fixed in the next release!


Great. I have the same issue on Android Tab S9+.

Thanks for reporting this. I’m having the same issue on iPadOS, whereas on macOS my hotkeys are working as expected. Looking forward to this being solved in next release. (I am very new to Obsidian - how long can I expect until next release?) Edit: using version v1.5.8 (126).

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.