Toggle %%comment%% command and cursor position

Steps to reproduce

  1. Open Sandbox vault.
  2. Type cmd + / in a note to run the Toggle comment command.

Did you follow the troubleshooting guide? Y

Expected result - (behavior of Obsidian v1.4.16)

%% <cursor here> %%

Actual result - (behavior of Obsidian v1.5.3)

<cursor here> %% %%


macOS 14.2.1

Obsidian version: v1.5.3
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:53:18 PST 2023; root:xnu-10002.61.3~2/RELEASE_ARM64_T6000 23.2.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 0
Plugins enabled: 0


Additional information

  • This came up a bit ago on Discord.
  • I searched here but didn’t find this exact issue.
1 Like

I can also confirm this although I recommend adopting using more elegant <!-- comment --> syntax which offers built‑in compatibility with other software.


will be fixed 1.5.4

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.