Todoist Plugin error, please help: "Request failed, status 429"

Things I have tried

Reloading obsidian. (no change)
Checking Todoist to see that it works (it does)
Tried it on a different machine / operating system (same error on both Linux and Windows, but not Android)

What I’m trying to do

I don’t know what the error message represents.
I just want the plugin to work and sync Todoist tasks like it did yesterday and the day before.

If you google it, it says “too many requests”.

So you may have reached your API limits in your Todoist account. There might be a place to check that on the Todoist website inside your account settings.

2 Likes

I get this error all the time. I have one todo note that should just make 3 requests every time it loads, but I often only see these errors. Is the plugin making more requests than it needs or is Todoist just really strict with how many requests they allow?

Their website says you can make 450 API requests every 15 minutes. I shouldn’t be getting this error so frequently so idk whats going on

I’ve just tried deleting 3 other services that were calling on Todoist, (leaving the plugin as the only API call) in case the fault was coming from one of them.

I am getting this error also - I think there must be a new bug/malfunction/unhelpful setting somewhere in Obsidian, the plugin or at Todoist (I suspect the latter), because I wasn’t getting this error previously.

The plugin seems to have stopped working altogether now, even after waiting a number of minutes to let any timed limit expire. Can’t get it to work on WIndows, iPhone or iPad. Earlier I was able to get it to work but it was reporting “Unknown project” against each to do item.

Maybe there is not enough bandwidth on the Todoist server. I am going to try to raise a query with them.

I have lodged the following support request with Todoist:
"Obsidian Todoist plugin is reporting a 429 Too Many Requests error. I am using it via the API. It was working earlier today. Then it kept saying that the project was unknown. Now it is not working at all and says “Error: Too Many Requests or on iPad it refers to Request failed, status 429. I have tried waiting a while but still not working. I have been on the Obsidian forum and apparently I am not the only one experiencing this error today. It something up with your server?”

And it’s back for a minute, then gone again.

Another user reported this:
“I was having the same issue and I increased my Auto Refresh Interval in the module’s settings from 60 seconds to 600 seconds. I did it just a day or two ago but it has been stable since then.”

1 Like

See Is Todoist down ? - YouTube - 15 hours ago - another user having problems and suggesting a problem at Todoist - apparently error reports have surged - I have not been able to verify this.

beadwood, thanks for your solution, though this does not work in my case unfortunately.

These issues have now all resolved for me , i.e. all working again as expected.

Ah no, they’ve come back.

I heard from Todoist - they say that “Based on what we are seeing our logs it is starting to look like Obsidian may need to make some changes to how they are calling the Todoist API.”

I am trying to put them in touch with Obsidian.

I changed the refresh interval to 3600 seconds and the problem has not recurred (yet anyway).

How exactly are you doing that? I assume you’re using a Todoist plugin. I see a few of them in the community plugins directory.

This will be a matter of politely logging an issue in the community plugin’s project in Github. Remembering that these are freely offered tools. Support is not guaranteed.

Obsidian and the devs can’t offer support for your 3rd party plugins, or your Todoist account.

Problem has recurred. Changing the refresh interval was not a permanent solution.

Rigmarole, hi. I did ask Obsidian whether they could assist, via their support facility, assuming wrongly that when a plugin was on the Obsidian site there would be a conversaition between Obsidian and the developer and/or the party whose API was being used. They politely put me straight. A noob error, but thanks for pointing it out. There is already an issue logged on Github, though no-one (including the developer, who had already commented, and was anticipating a possible update) was clear on the cause of the problem. I asked Todoist if there was something up with their server. They looked at their logs and offered to discuss the issue with the developer with a view to finding a solution. I passed that offer onto the developer.

1 Like

Currently all is working for me, so thanks to the dev not only for this great plugin but also for any tweaks that may now have been applied.