[[ to create a link doesn't work

What I’m trying to do

I’m trying to create a link using the “[[” procedure documented in Obsidian Help; i.e., select the text and type [[ – see Internal links - Obsidian Help

Things I have tried

I believe I did exactly what that section said to do:

  1. double-clicked on the word to highlight it
  2. typed “[[”

What it actually does is apply the vim [[ command - :h [[ - and selects backwards to the previous sentence.

I also tried Ctrl-K which was written about in another topic here (feature request) and all that does is delete the word.

Is there any way to create a link from existing text without just having the create the whole thing manually?

I’m on a Mac with Obsidian v1.3.4

Do you have Settings > Editor > “Vim key bindings” enabled? I don’t know if that causes the behavior you’re seeing, but it sounds plausible.

Have you turned off Settings > Editor > Auto pair brackets? That needs to be on for the action you’re attempting to work. Or maybe you need the auto-pair Markdown setting, even tho wiki links aren’t technically Markdown — one of those is required.

Yes, I’m using vim so I guess that overrides the default Obsidian behavior.
Thanks much…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.