TikZJax extension inverting colors after render

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

What I’m trying to do

I am creating a binary search tree using the TikZjax extension in Obsidian. TikZjax renders the tree correctly, but there is a problem with the color. At first, it renders with the default white color, but after navigating to other files and coming back to the file containing the diagram, it reverts to a dark color so I cannot see the nodes correctly.

Things I have tried

I have tried re-writing the code, changing themes, and restarting the client to no avail.

image

I’m not able to reproduce this using a random chemfig structure from the plugins help pages. Tried switching windows, going back and forth in the page history, but it never reverted the colors.

But I did see an option in Settings > TikZJax called Invert dark colors in dark mode. You do have this enabled, yes?

Which version of the plugin are you using, and which theme? And how do you define your figure? I’m not sure we’re able to help you even with this information, as it kind of sounds like it’s a plugin issue which you might need to post on their github page: Issues · artisticat1/obsidian-tikzjax · GitHub

A quick look through on the issue list, seems to indicate that this is a somewhat known issue: Color inversion only sometimes being applied · Issue #15 · artisticat1/obsidian-tikzjax · GitHub And for some it’s a matter of changing between live preview and reading mode to get the correct output, or possibly to reduce the number of figures on a given page.