TikZJax drawing not rendering

What I’m trying to do

I want to display a number line for visualization purposes and found the extension TikZJax. I installed the extension, enabled it and pasted the sample snippet in the presentation page:

```tikz
\begin{document}
  \begin{tikzpicture}[domain=0:4]
    \draw[very thin,color=gray] (-0.1,-1.1) grid (3.9,3.9);
    \draw[->] (-0.2,0) -- (4.2,0) node[right] {$x$};
    \draw[->] (0,-1.2) -- (0,4.2) node[above] {$f(x)$};
    \draw[color=red]    plot (\x,\x)             node[right] {$f(x) =x$};
    \draw[color=blue]   plot (\x,{sin(\x r)})    node[right] {$f(x) = \sin x$};
    \draw[color=orange] plot (\x,{0.05*exp(\x)}) node[right] {$f(x) = \frac{1}{20} \mathrm e^x$};
  \end{tikzpicture}
\end{document}
.```

Unfortunately when i click away from the text box i just get an infinite rendering loop and no output is displayed

Things I have tried

I tried closing and reopening obsidian, reinstalling the extension and looking online but I can’t find anyone else having this problem

It works with no problem in my case.

Try

  1. Delete dot . before ``` (at the end)
  2. Disable another plugins
  3. Disable or enable: Hardware acceleration
    path: SettingsAboutHardware acceleration

Sorry for the confusion, the dot isn’t there in the actual snippet. I’ll try the other two options

EDIT: The only other plugin is dataview, i toggled it on and off and it started working correctly, thank you very much

PS: nice username xD say hi to Mina for me

1 Like