This flag is broken in 0.14.15 --disable-features=ForcedColors

I just had Obsidian automatically upgraded from 0.14.6 to 0.14.15. All the colors were immediately ruined. After I investigated, I found that the --disable-features=ForcedColors flag that I pass to Obsidian seems to be ignored now. It’s a Chrome flag which is absolutely necessary for legible colors on my high-contrast Windows theme.

Did you do anything specific about this flag? Could you think of a reason why it’s not being passed forward to Electron?

Thanks for your help,
Ram Rachum.

Not really. You can try to download and reinstall obsidian. Maybe the newer electron version it contains will fix your issue.

I tried reinstalling 0.14.15 but the problem still happened. The only thing that helped was uninstalling Obsidian, deleting my C:\Users\Administrator\AppData\Roaming\obsidian folder and installing Obsidian 0.14.6.

Can you check whether any change in the code could have caused this? This flag is very important to me, and I can’t upgrade Obsidian without it.

We have an idea what happened. This maybe a byproduct of working around another bug. We’ll try to fix this in the next release.

Thanks, I’ll follow up.