The theme, hotkeys, and community plugins on my main vault have disappeared

Things I have tried

restarting program multiple times; restarting computer; posting in a forum which MIGHT help?

What I’m trying to do

I’ve spent the past three months building a vault that’s efficient and helpful to me. All of that (except the files) is gone now and I’d like to get it back. When I opened the computer this morning I loaded obsidian but I didn’t get a chance to actually go into it before we lost power and my computer died (my battery is fried). When I rebooted and opened again the theme, plugins, and hotkeys are gone from my main obsidian vault. Other vaults, which I don’t use as often, are unaffected. Can anyone help?

Hmm. It sounds like something might have corrupted because of the power failure. You don’t have backups, do you?

I think I do, actually! I copied the vault files onto a thumb drive sometime last week when the computer started being weird. What do you suggest I do?

(Though, this is not the first time the computer has randomly shut down in the past few days because of power loss, and it’s always been fine before. Would liquid damage affect just THESE files? Everything else so far in my computer looks fine; no other weird file disappearance and as I said, all other vaults are normal.)

Step one, I’d suggest backing up your corrupted vault as well, before trying to fix it. That way, if anything goes wrong while fixing, you can roll back and try again.

And then inside your vault, there should be a hidden .obsidian folder. Depends on your OS how to show hidden files. But if you delete that and replace it with the one from your backup, it should restore your plugins, themes, and your workspace layout. You may have to reinstall any plugins you installed after the backup was taken.


If that doesn’t work, there may be a chance some of the files in your Obsidian app folder got corrupted. I personally have no idea what may go wrong if that happens. But I don’t believe the contents of your vault will really be affected by that folder. So if you had to, reinstalling Obsidian might fix that.
Again depends on your OS. In Mac it’s ~/Library/Application Support/obsidian

Thank you for this! Will see what I can find re: hidden files, etc. Am using windows 10, so will hunt around for it.

Edit to add: if I copy the file highlighted in blue (the .obsidian file from the backup/uncorrupted vault), then delete that same file in the desktop (corrupted) version, and replace it with this… is this what you meant? Thanks for your patience/help!

Screenshot (1506)|690x387

Yep, you have it right. Fingers crossed here.

1 Like

YOU ARE THE BEST. Thank you so much- it worked within seconds!! Everything back to normal.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.