The operation can’t be completed because an item with the name “xx” already exists

Things I have tried

  • Relaunching Finder, Restart Mac
  • Clearing MacOS /Library/Cache
  • Emptying Obsidian .trash folder
  • Individually removing ‘duplicate’ file. A different file pops up with the same error
  • Changing destination

What I’m trying to do

  • Move my Obsidian Vault to a different location
  • My vault (with Obsidian Sync enabled) is stored locally and synced with Google Drive. I started getting ‘File has been externally modified’ errors while editing notes in Obsidian which I thought might be due to having 2 sync options. So I’m trying to move the Vault out of Google Drive but am encountering this problem. Somehow all the notes affected are within ‘/Daily Notes’ folder

Error encountered

(Yes, I’ve triple checked. No such file exists at my destination)

Google Drive (Intel)
MacOS Big Sur 11.5.2

Nvm, I managed to solve it by individually moving folders. I’m still not sure why it happened but it’s worked out now. As a precaution, I’m setting up new Sync Vaults and re-uploading my latest vaults in case there are any existing sync errors.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.