The "Open another vault" window won't display correctly or work

Steps to reproduce

  1. Install the AppImage for Obsidian
  2. Give the AppImage the permissions necessary to run it as a program
  3. Open the AppImage, then either create a new vault or open an existing directory as a vault
  4. Click on “Open another vault” in the sidebar

Expected result

Clicking on “Open another vault” should bring up the corresponding window and display it correctly.

Also, clicking on the options should perform the respective actions.

Actual result

Clicking on “Open another vault” opens the window, but it’s translucid.

The options are still clickable because if I hover the mouse over where they are, the mouse changes. Also, hovering the mouse over the text next to the options changes the mouse as well. However, clicking on the first two options does nothing. Only the last option works, but it brings up yet another translucid window.

Environment

  • Operating system: Ubuntu 16.04 LTS
  • Obsidian version: 0.11.13

Additional information

  • See this image showing the translucid window
  • The window displayed correctly and worked when I first ran Obsidian and was prompted to create a new vault or open an existing folder as a vault
  • I’ve installed a few third-party plugins, but they’re probably not faulty for this because even with Safe Mode on the problem persists
  • I’ve added a dot to the beginning of the filename of the AppImage to hide it: “.Obsidian-0.11.13.AppImage”

I can’t reproduce. Please, Post a screen recording of this happening in the happening in the help vault.
THis may be a problem of your specific OS version.

Here goes a recording made using my smartphone. Hope this suffices.

Also, on the making of the first video, I discovered that using Super+[Arrow keys] does some weird things to the Obsidian window. See this video for that.

This may be a problem with my specific OS as you say. Is there anything I can do about this?

I am sorry but I can’t reproduce this. I am gonna move this to help section as I believe this is due to incompatability between your (outdated) window manager and Obsidian/Electron.

I’ll try updating to the latest version of Ubuntu.

I’ll get back to you once I’ve done so and tested if the problem persists.

I’ve solved it!

You were right: this is an issue of Ubuntu 16.04 LTS.

I upgraded to 21.04, and Obsidian works perfectly.

Thank you for your help!