The iPhone does not respond after startup, just a black screen

Steps to reproduce

I followed the instructions in the documentation at After creating a new library [test] on the iOS side, I could not find this library [test] on the desktop. However, after I uninstalled and reinstalled Obsidian on my phone, I could see and synchronize this library [test] again. In order not to leave no test files in the system, I deleted all Obsidian-related files from iCLoud, uninstalled and reinstalled. As a result, there is no response after I start Obsidian, only a black screen.

Did you follow the troubleshooting guide? [Y/N]


Expected result

It is expected that it can be used normally after installation

Actual result

Unable to start and use normally, only black screen displayed


Unable to provide debug info because there is nothing on the page

Additional information


If you deleted your vault (all Obsidian-related files) from iCloud Drive with Obsidian still open or in memory, it seems likely it would act strange.

I’d try force quitting (swiping the app up and away) or restarting the phone. You should be presented with the initial create vault screen when you launch Obsidian.

Another option is creating a vault on the desktop (in iCloud) and waiting for it to sync over to the phone.

Yes, I have tried force quitting, shutting down and restarting, uninstalling and reinstalling, etc., and also tried restoring all settings in the iPhone settings.

After reopening the app, there is only a black screen and create vault is not displayed.