The file duplicated itself

I describe what happened to me: (after) I realized that I had opened the same file in two tabs. In the second one I changed the file name and the result was having the duplicate file, one with the old name and contents and one with the new name with the changes made.

I was just making some test changes but I would have expected that if the file is open in multiple tabs it would be automatically synchronized, or rather, get an alert indicating that the file is open in multiple tabs and ask whether to create two copies or synchronize them in real time.

Steps to reproduce

The note was open in two tabs
I changed the title of the note in the second tab

Did you follow the troubleshooting guide? [Y/N]

Yes
In fact, in the sandbox I could not recreate the problem.
I have only been creating the vault for a week and it is unlikely that I have messed up. In the vault I had opened the tabs side by side and also linked together. I would not know how best to describe the configuration.
The active third-party plugins are: DataView and Templater

Expected result

It may be that I inadvertently selected the note in the first tab and the program thought I wanted to edit it and, to avoid conflict, created a copy. However, a warning with a request for what to do would have been helpful.
So would an alert telling me if I am trying to open a note in a tab of a view where it is already open, or alerting me if it is open in another view but hidden.

Actual result

The note duplicated itself without asking

Environment

SYSTEM INFO:
Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: Windows 10 Education 10.0.19045
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 3
Plugins enabled: 2
1: Dataview v0.5.64
2: Templater v1.18.3

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

I have already deleted the duuplicate, I cannot show it, sorry

Moved to Help for now.

@AP2023 Have you been able to reproduce this in the vault where it happened?

Also, you mention in the “troubleshooting guide” section that the tabs were linked — that should be under “Steps to reproduce”.

No, I could not reproduce the problem again. Not even in the same vault.

Don’t notifications come via email when someone replies to a discussion I’m following?

You can enable emails in your user settings. I don’t remember what the default is (mine is off so I’m guessing that’s the default but not sure).

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.