The custom location of new notes is reset everytime I reopen Obsidian

What I’m trying to do

Hello. Whenever I go to Settings > Files and links > Default location for new notes > Folder to create new notes in, the changes will be reset next time I open Obsidian. The current folder is called “Inbox”, and I am trying to change it to “100 Inbox”, as I modified the name of the folder.

I noticed however that new notes are actually just created in the vault, not even in a new “Inbox” folder. It worked well before I changed the name to 100 Inbox.

Things I have tried

I suspect that a plugin is interfering here, so I tried to check them all, but I couldn’t find the culprit. Here they are, if that may be useful.

1: Zotero Integration v3.1.7
2: Auto Link Title v1.5.3
3: Better Word Count v0.10.1
4: Callout Manager v1.0.1
5: Commander v0.5.1
6: Convert url to preview (iframe) v0.5.0
7: DataLoom v8.15.11
8: File Color v1.1.0
9: Highlightr v1.2.2
10: Kanban v1.5.3
11: List Callouts v1.2.0
12: Mind Map v1.1.0
13: Minimal Theme Settings v7.3.1
14: Note Refactor v1.8.2
15: Outliner v4.8.0
16: Projects v1.17.1
17: Recent Files v1.3.10
18: Reference Map v1.8.1
19: Style Settings v1.0.7
20: Tag Wrangler v0.6.1
21: Workspaces Plus v0.3.3
22: TickTick v1.0.4
23: Tasks v6.0.0
24: Hover Editor v0.11.16
25: Dataview v0.5.64
26: BRAT v0.8.3
27: Query Control v0.6.0
28: Metadata Menu v0.7.7
29: Git v2.23.1
30: Advanced Tables v0.21.0

Are you using a service to Sync your notes between different devices? They can often cause problems like this

I do! Github, with the Git plugin. Thank you!

The folder needs to be created already before you can select it in Default location for new notes → Folder to create new notes in, but it sounds like you’ve done that already. (If you just type in a folder name that isn’t created, it will be accepted when you click out of Settings, but it won’t work.)

That setting is saved in the {VAULT}/.obsidian/app.json file (along with other main settings), so I’d keep an eye on that file to see if something is messing with it, it’s ignored or not get synced properly with Git, etc.

Hi, thanks for the reply.

The folder is indeed create, called “300 Inbox”. What’s curious is that I don’t have an “Inbox” folder anymore, and creating a new note won’t create it either, it will just create a note in the vault. Chaning the value to “300 Inbox” in the app.json file has the same temporary effect of fixing it until next time Obsidian is open.

On Github, it shows the 300 Inbox folder so I’m not sure where to go from here.

Apologies, I didn’t mean for you to edit the app.json file yourself. It was just an example of the saved state.

Oh ok, nevermind then. Do you have any idea where I could look to fix the issue then?