Text rendering artifacts in nested callouts when Wayland fractional scaling is enabled

Steps to reproduce

Open a Sandbox vault and paste the following in a file:

> [!info]+ asdfasdf asdfasdf asdfasdf
> > [!tip] asdfasdfas asdf asdf asdf asdf asdf asdf asd fas
> > * **asdfasdf**, asdfasdfasdf.
> > * **asdfasdf** asdfasd fasdfasdf asdf asdfasd ffasf.
> > [!tip] asdfasdf asdf asdfasdf as dasdf asdf as
> > * **asdfasdf** asdfsd fadfaasdf a;slkdj ffas a;lsdjkf asdf, e.g., asdfasdf.
> > * **asdfasdf** asdfasdfasdf a;sdlkfj a;lsdkj f;jdfsad
> > * fasd;flkjasd;fjkl as;ldfkj as;ldjf
> > [!tip] asdfasdf asdfadsf asdf asd fasdfs
> > asdfasdf asd fasd fasd fasd fasd fasdf as;dlfk j;aslkd jf;aslkdfj klajsd;lfkjasd;lfk jas;dlkfj as;ldkfj as;lkdjf; alskdj f;laksj df;lakjsdf ;laksjdf;lkjasd;fl k jasd;lfk jas;dlkfj as;ldkjf a;slkjdf ;laskjdf ;laskjd ;flk.; laks;lajksd f.
> > 
> > > [!abstract] fasdf a fads f.
> > [!tip] alsk;dj f;alkjs df;laksjd f;laksjd f;lasjkdf
> > a;sldkj fa;lskdj f;alskj df;alskdj f;asdjf ;alskdj f;alksdjf ;alsdkjf alsd;lfkjas d;flkj asd;lfkjas;dlfj. asd $\to$ jkl $\to$ dfgh.

Expected result

No text rendering bugs/artifacts.

Actual result

Weird artifacts. Disappear when that block of text is selected. Appear again when that block of text moves (due to scrolling, zooming, typing, etc.).



  • Operating system:
    Fedora Linux 37 (Workstation Edition). GNOME 43.3. Wayland. Linux 6.2.7-200.fc37.x86_64.

  • Debug info:

	Obsidian version: v1.1.16
	Installer version: v1.1.16
	Operating system: #1 SMP PREEMPT_DYNAMIC Fri Mar 17 16:16:00 UTC 2023 6.2.7-200.fc37.x86_64
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 2
	Restricted mode: off
	Plugins installed: 4
	Plugins enabled: 4
		1: Vimrc Support v0.9.0
		2: Calendar v1.5.10
		3: Shell commands v0.18.1
		4: Excalidraw v1.8.14

	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

  • I use 125% scaling (Wayland) on a 2560x1440 screen. The laptop has an NVIDIA RTX 3060 with a multiplexer. Obsidian probably runs on the Alder Lake iGPU (at least nvidia-smi says so).
  • Obsidian was installed using Flatpak and the OBSIDIAN_USE_WAYLAND=1 variable was exported to the application using Flatseal.
  • The artifacts do not appear outside nested callouts (that’s why I discovered them so late!).

Screenshot from 2023-03-25 12-01-16

Screenshot from 2023-03-25 12-01-37

Screenshot from 2023-03-25 13-25-45

not much we can do here, this is chrome/electron/wayland problem.

It’ll be fixed upstream at somepoint.

You may be able to work around this by disabling GPU acceleration: