Text is being select all by itself when typing

I am running Obsidian on a samsum tab S8+ android 13 latest update from yesterday. Today, when I start typing, the entire text becomes selected thus i am unable to write any notes. is there any settings, or things I could look at to troubleshoot further

Things I have tried

shut down and restarted the app
reinstalled the app from scratch

What I’m trying to do

1 Like

I am running the latest updates on a Samsung S7 Tablet. For about a week I have been unable to use Obsidian on my tablet. I can type half a sentence and then the entire note is selected as if I hit Ctrl+A and am then unable to continue typing.

I have disabled plugins and the issue remains.

I use a Samsung cover keyboard to type and have tried disconnecting this and using the on screen keyboard, which seems to resolve but is not a solution for me. The keyboard is up to date and there are no issues when typing a few paragraphs within Microsoft Word, or while typing this comment on the forum in Chrome.

Any help will be much appreciated.

1 Like

Some suggestions I’ve heard for text issues on Android are changing your software keyboard and/or disabling predictive text.

Thanks for the suggestion arielhen, I had actually already tried this and it hasn’t rectified the issue…

I thought the issue had resolved itself however it repeated again yesterday.

I’m not sure if this is a conflict with Templater, because my Daily Note Template typically pulls in the following structure for navigation:
image

However, yesterday’s note on the Note S7 Tablet pulled in the template correctly, but then when typing the note changes certain characters in the note without input to something that isn’t recognised when loading the same note through Sync on my PC today…
image

Any (relevant) ideas are welcome.

What kind of sync software are you running on the android device?

Could you possibly turn that off temporarily and see if that rectifies your issue?

1 Like

I’m using Obsidian Sync. The issue doesn’t happen on my Android phone, just on the tablet…

I was having the exact same issue, and was also having the issue with the “OBJ” text that Xeon mentioned. What worked for me was setting a different digital keyboard other than samsung keyboard.

I downloaded Gboard off the play store, set it as my default, turned off predictive text, and restarted my tablet. (Using a galaxy tablet S7)

1 Like

i am having a similar issue… it kinda works when i change a digital keyboard as default but kinda on and off? also… is it just me or does the right click on the samsung keyboard cover also not work?

Hi there - Same tablet - same issue.
No change after tablet update / Obsidian re-install.

Have thought about the keyboard… not convinced…

Has - what you did - made a difference?

For me - Samsung tab S7+ - same issue: with or without sync software.

I have mainly been using my PC or phone for Obsidian recently but tonight used my Tablet and it happened again. It selects all as soon as I pause typing for longer than a second. Chatting to Samsung Tech Support they suggested cleaning the three contacts/prongs between the keyboard and the tablet. They sent over some other steps which I haven’t tried yet as the issue has disappeared again for now. It tends to take a few minutes within a note to show up so I will monitor it and then go through the other steps to see if any of those fix the issue if this one doesn’t. I will post back here for others to try.